aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-03-28 17:06:49 +0100
committerTed Tanberry <ted.tanberry@gmail.com>2015-03-28 17:06:49 +0100
commite9842579c0fcb075170d823068ec4bfa4fbf8cda (patch)
tree91ff69131b90ffffa3899486dcc7e8b60123fbc4 /eclass
parentsci-biology/tablet-bin: Update HOMEPAGE (diff)
downloadsci-e9842579c0fcb075170d823068ec4bfa4fbf8cda.tar.gz
sci-e9842579c0fcb075170d823068ec4bfa4fbf8cda.tar.bz2
sci-e9842579c0fcb075170d823068ec4bfa4fbf8cda.zip
Updated emboss-r1.eclass and all embassy/emboss packages to confirm to QA standards.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/emboss-r1.eclass20
1 files changed, 5 insertions, 15 deletions
diff --git a/eclass/emboss-r1.eclass b/eclass/emboss-r1.eclass
index e82b413ba..00d00f7ad 100644
--- a/eclass/emboss-r1.eclass
+++ b/eclass/emboss-r1.eclass
@@ -38,17 +38,14 @@
# @ECLASS-VARIABLE: EBO_EXTRA_ECONF
# @DEFAULT_UNSET
# @DESCRIPTION:
-# Extra config options passed to econf, similar to EXTRA_ECONF.
+# Extra config options passed to econf, similar to EXTRA_ECONF
+# but can be set by the ebuild.
case ${EAPI:-0} in
5) ;;
*) die "this eclass doesn't support < EAPI 5" ;;
esac
-if [[ -f "${FILESDIR}"/${P}_fix-build-system.patch ]]; then
- AUTOTOOLS_AUTORECONF=1
-fi
-
inherit autotools-utils eutils flag-o-matic
HOMEPAGE="http://emboss.sourceforge.net/"
@@ -88,20 +85,15 @@ fi
# @DESCRIPTION:
# Does the following things
#
-# 1. Patches with "${FILESDIR}"/${P}_fix-build-system.patch, if present,
-# and eventually runs eautoreconf in autotools-utils
-# 2. Patches with "${FILESDIR}"/${PF}.patch, if present
-# 3. Applies ${PATCHES[@]} via autotools-utils.eclass
+# 1. Renames configure.in to configure.ac, if possible
+# 2. Applies ${PATCHES[@]} and runs autotools via autotools-utils.eclass
#
emboss-r1_src_prepare() {
- if [[ -f "${FILESDIR}"/${P}_fix-build-system.patch ]]; then
+ if [[ -e configure.in ]]; then
mv configure.{in,ac} || die
- epatch "${FILESDIR}"/${P}_fix-build-system.patch
fi
- [[ -f "${FILESDIR}"/${PF}.patch ]] && epatch "${FILESDIR}"/${PF}.patch
-
autotools-utils_src_prepare
}
@@ -118,7 +110,6 @@ emboss-r1_src_prepare() {
# --enable-large
# --without-java
# --enable-systemlibs
-# --docdir="${EPREFIX}/usr/share/doc/${PF}"
# ${EBO_EXTRA_ECONF}
emboss-r1_src_configure() {
@@ -131,7 +122,6 @@ emboss-r1_src_configure() {
--enable-large
--without-java
--enable-systemlibs
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
${EBO_EXTRA_ECONF}
)