aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2012-01-08 16:49:57 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2012-01-08 16:49:57 +0100
commit1afb461b204933db48bfe976a37203c92846930d (patch)
treeb06b4dbb5ae68b8574c431421e8fa04074ac22e2 /sci-biology/artemis/artemis-9999.ebuild
parentdev-python/GOGrapher: more robust version from same author is at https://gith... (diff)
downloadsci-1afb461b204933db48bfe976a37203c92846930d.tar.gz
sci-1afb461b204933db48bfe976a37203c92846930d.tar.bz2
sci-1afb461b204933db48bfe976a37203c92846930d.zip
sci-biology/artemis: DNA sequence viewer, annotation (Artemis) and comparison (ACT) tool
Diffstat (limited to 'sci-biology/artemis/artemis-9999.ebuild')
-rw-r--r--sci-biology/artemis/artemis-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/artemis/artemis-9999.ebuild b/sci-biology/artemis/artemis-9999.ebuild
new file mode 100644
index 000000000..ff8d52d17
--- /dev/null
+++ b/sci-biology/artemis/artemis-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit java-pkg-2 java-ant-2
+
+[ "$PV" == "9999" ] && inherit git-2
+
+DESCRIPTION="DNA sequence viewer, annotation (Artemis) and comparison (ACT) tool"
+HOMEPAGE="http://www.sanger.ac.uk/resources/software/artemis"
+
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/sanger-pathogens/Artemis"
+ KEYWORDS=""
+else
+ SRC_URI="ftp://ftp.sanger.ac.uk/pub4/resources/software/artemis/v13/v"${PV}"/artemis_compiled_v"${PV}".tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sci-biology/samtools
+ sci-biology/bamview
+ >=virtual/jdk-1.5
+ >=dev-java/sun-jdk-1.5
+ dev-java/ant-core"
+RDEPEND="${DEPEND}
+ >=virtual/jre-1.5"
+
+src_compile() {
+ ant compile || die
+
+ einfo "Need to figure out where does the GeneBuilder application come from so that one could use Chado for automated gene prediction pipeline"
+}