aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-03-24 02:41:35 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-03-24 02:41:35 +0100
commit5c73aaa78d02e3b384be3b52120625ed8b507e19 (patch)
treecc69d8177fd0ef91cbad832dbe607c6ce76cbda1 /sci-biology/freebayes/freebayes-9999.ebuild
parentsci-biology/pileup: dropped KEYWORDS due to misisng LICENSE (diff)
downloadsci-5c73aaa78d02e3b384be3b52120625ed8b507e19.tar.gz
sci-5c73aaa78d02e3b384be3b52120625ed8b507e19.tar.bz2
sci-5c73aaa78d02e3b384be3b52120625ed8b507e19.zip
sci-biology/freebayes: a new package skeleton; need to retrive from git in a recursive way
Diffstat (limited to 'sci-biology/freebayes/freebayes-9999.ebuild')
-rw-r--r--sci-biology/freebayes/freebayes-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/freebayes/freebayes-9999.ebuild b/sci-biology/freebayes/freebayes-9999.ebuild
new file mode 100644
index 000000000..0876efbb2
--- /dev/null
+++ b/sci-biology/freebayes/freebayes-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+[ "$PV" == "9999" ] && inherit git-2
+
+DESCRIPTION="Bayesian genetic variant detector designed to find small polymorphisms: SNPs, indels, MNPs and complex events"
+HOMEPAGE="https://github.com/ekg/freebayes"
+EGIT_REPO_URI="git://github.com/ekg/freebayes.git"
+
+# need top checkout vcflib/ as well
+#
+# To build freebayes you must use git to also download its submodules.
+# Do so by downloading freebayes again using this command (note --recursive flag):
+# git clone --recursive git://github.com/ekg/freebayes.git
+#
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sci-biology/bamtools
+ sci-biology/samtools"