aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-16 10:53:34 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-16 10:53:34 +0100
commit5f3f4d9525b701b6643ecbdfa3835051201c6e25 (patch)
tree8c47df4165f4995438aba4952b6a3d29b50ac6a3 /sci-biology/freebayes/freebayes-9999.ebuild
parentDrop quoting form EAPI (diff)
downloadsci-5f3f4d9525b701b6643ecbdfa3835051201c6e25.tar.gz
sci-5f3f4d9525b701b6643ecbdfa3835051201c6e25.tar.bz2
sci-5f3f4d9525b701b6643ecbdfa3835051201c6e25.zip
sci-biology/freebayes: force compilation in a single thread as parallel build fails
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/freebayes/freebayes-9999.ebuild')
-rw-r--r--sci-biology/freebayes/freebayes-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-biology/freebayes/freebayes-9999.ebuild b/sci-biology/freebayes/freebayes-9999.ebuild
index b4eee4419..1b1eb89ed 100644
--- a/sci-biology/freebayes/freebayes-9999.ebuild
+++ b/sci-biology/freebayes/freebayes-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -84,6 +84,10 @@ RDEPEND="${DEPEND}
# g++ -O3 -D_FILE_OFFSET_BITS=64 -g -I../ttmath -I../bamtools/src/ -I../vcflib/src/ -I../vcflib/tabixpp/ -I../vcflib/smithwaterman/ -I../vcflib/multichoose/ -I../vcflib/filevercmp/ -I../vcflib/tabixpp/htslib -I../SeqLib -I../SeqLib/htslib -c freebayes.cpp
+src_compile(){
+ emake -j1 # vcflib/smithwaterman/ sometimes does not compile
+}
+
src_install(){
dobin bin/freebayes bin/bamleftalign
}