aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-07 19:43:23 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-07 19:43:23 +0100
commitae08d9c024267a4b6a06d53126ec88ff80f748fc (patch)
tree368996a084f6ee7c57ae2ff7ac159e35a91f13b4 /sci-biology/grass/grass-9999.ebuild
parentsci-biology/trinityrnaseq: upstream removes fasta_tool script in future versions (diff)
downloadsci-ae08d9c024267a4b6a06d53126ec88ff80f748fc.tar.gz
sci-ae08d9c024267a4b6a06d53126ec88ff80f748fc.tar.bz2
sci-ae08d9c024267a4b6a06d53126ec88ff80f748fc.zip
sci-biology/grass: introduce -9999 live version, drop old
fix the build system (https://github.com/AlexeyG/GRASS/issues/6) Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/grass/grass-9999.ebuild')
-rw-r--r--sci-biology/grass/grass-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/grass/grass-9999.ebuild b/sci-biology/grass/grass-9999.ebuild
new file mode 100644
index 000000000..2f592d28c
--- /dev/null
+++ b/sci-biology/grass/grass-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-r3 eutils
+
+DESCRIPTION="Scaffold next-generation sequencing assemblies"
+HOMEPAGE="https://github.com/AlexeyG/GRASS"
+#SRC_URI="https://github.com/AlexeyG/GRASS/archive/master.zip -> grass-20130628.zip
+# https://tud-scaffolding.googlecode.com/files/GRASS%20manual.pdf -> grass_manual.pdf"
+EGIT_REPO_URI="https://github.com/AlexeyG/GRASS.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# some IBM development CPLEX library?
+# ilcplex/ilocplex.h: No such file or directory
+# https://github.com/AlexeyG/GRASS/issues/6
+DEPEND="sci-biology/bamtools
+ sci-biology/ncbi-tools++
+ sys-cluster/openmpi"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ epatch "${FILESDIR}"/fix_Makefile_variablenames.patch
+# sed -e 's#/data/bio/alexeygritsenk/apps/include/ncbi-tools++#/usr/include/ncbi-tools++#' -i Makefile.config || die
+# sed -e 's#/data/bio/alexeygritsenk/apps/include/#/usr/include/bamtools#' -i Makefile.config || die
+# sed -e 's#/data/bio/alexeygritsenk/apps/lib#/usr/lib64#' -i Makefile.config || die
+}
+
+src_compile(){
+ emake all
+}
+
+src_install(){
+ newdoc manual/manual.pdf grass_manual.pdf
+ dobin bin/*
+}