aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-02-01 13:28:19 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-02-01 13:28:19 +0100
commitc555a18358d85d307fae9f4f0b13ef2d9b8376b5 (patch)
tree984352196f8bf52bede913c591a270c50f5ecb05 /sci-libs/fftw
parentDrop dev-util/amdapp-2.8 (diff)
downloadsci-c555a18358d85d307fae9f4f0b13ef2d9b8376b5.tar.gz
sci-c555a18358d85d307fae9f4f0b13ef2d9b8376b5.tar.bz2
sci-c555a18358d85d307fae9f4f0b13ef2d9b8376b5.zip
sci-libs/fftw: Convert to CPU_FLAGS_X86
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog6
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild14
-rw-r--r--sci-libs/fftw/metadata.xml2
3 files changed, 12 insertions, 10 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index cedc57e84..cae3ff907 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-libs/fftw
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Jan 2015; Marius Brehler <marbre@linux.sungazer.de> fftw-9999.ebuild,
+ metadata.xml:
+ Convert to CPU_FLAGS_X86 (adopted from tree)
+
04 Jul 2014; Justin Lecher <jlec@gentoo.org> fftw-9999.ebuild:
Drop reference to app-emulation/emul-linux-x86-soundlibs
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index 1b02b6299..78a157e3d 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -24,7 +24,7 @@ fi
LICENSE="GPL-2"
SLOT="3.0"
-IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
+IUSE="altivec cpu_flags_x86_avx doc cpu_flags_x86_fma3 cpu_flags_x86_fma4 fortran mpi neon openmp quad cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test threads zbus"
RDEPEND="mpi? ( virtual/mpi )"
DEPEND="${RDEPEND}
@@ -95,7 +95,7 @@ src_configure() {
fi
myeconfargs=(
- $(use_enable fma)
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
$(use_enable fortran)
$(use_enable zbus mips-zbus-timer)
$(use_enable threads)
@@ -106,15 +106,15 @@ src_configure() {
myeconfargs+=(
--enable-single
$(use_enable altivec)
- $(use_enable avx)
- $(use_enable sse)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_sse sse)
${enable_mpi}
$(use_enable neon)
)
elif [[ $x == double ]]; then
myeconfargs+=(
- $(use_enable avx)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_sse2 sse2)
${enable_mpi}
)
elif [[ $x == longdouble ]]; then
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
index 50e74c164..c6b1bd0e4 100644
--- a/sci-libs/fftw/metadata.xml
+++ b/sci-libs/fftw/metadata.xml
@@ -12,8 +12,6 @@
publicly available FFT software.
</longdescription>
<use>
- <flag name="avx">Adds support for Advanced Vector Extensions</flag>
- <flag name="fma">Use the Fused Multiply Add instruction set (fma3/fma4 either one)</flag>
<flag name="quad">Build quadruple precision lib</flag>
<flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
</use>