aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-01-17 21:30:13 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-01-17 21:30:13 +0100
commit300a1cee0484eb64da8b0ce8ee6c29388580b097 (patch)
tree82694c3ca9c4ac945d6d980cf25fcadf2fd05f82 /sci-libs/fox
parentAn ETSF IO ebuild for sci-physics/abinit (diff)
downloadsci-300a1cee0484eb64da8b0ce8ee6c29388580b097.tar.gz
sci-300a1cee0484eb64da8b0ce8ee6c29388580b097.tar.bz2
sci-300a1cee0484eb64da8b0ce8ee6c29388580b097.zip
A FoX ebuild for sci-physics/abinit
Diffstat (limited to 'sci-libs/fox')
-rw-r--r--sci-libs/fox/ChangeLog12
-rw-r--r--sci-libs/fox/Manifest6
-rw-r--r--sci-libs/fox/files/4.0.4-install-customizations.patch27
-rw-r--r--sci-libs/fox/fox-4.0.4.ebuild56
-rw-r--r--sci-libs/fox/fox-4.1.0.ebuild55
5 files changed, 156 insertions, 0 deletions
diff --git a/sci-libs/fox/ChangeLog b/sci-libs/fox/ChangeLog
new file mode 100644
index 000000000..4355c8cd8
--- /dev/null
+++ b/sci-libs/fox/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-libs/fox
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*fox-4.1.0 (17 Jan 2011)
+*fox-4.0.4 (17 Jan 2011)
+
+ 17 Jan 2011; Honza Macháček <Hloupy.Honza@centrum.cz>
+ +files/4.0.4-install-customizations.patch, +fox-4.0.4.ebuild,
+ +fox-4.1.0.ebuild:
+ A FoX ebuild for sci-physics/abinit
+
diff --git a/sci-libs/fox/Manifest b/sci-libs/fox/Manifest
new file mode 100644
index 000000000..e7544ce86
--- /dev/null
+++ b/sci-libs/fox/Manifest
@@ -0,0 +1,6 @@
+AUX 4.0.4-install-customizations.patch 993 RMD160 29b5a75de047adde3b3e468cab8d362fe591c240 SHA1 55b6987e80b7ff5e425ba140d2e44d088ed5ef1c SHA256 b8c283de0c6fe335c2bc524b988f5b46955fde7adca65d1da70ddfaa96f205c8
+DIST FoX-4.0.4-full.tar.gz 503516 RMD160 856aaf50564dd0d35e86f133e4fb1fbe7aa11ed3 SHA1 01ee568543cd17f14b6a63de177e6796f189ccb2 SHA256 219db37dcda0b11fa602170d76da086fe140cbfcbd9f8620a00482398c48836e
+DIST FoX-4.1.0-full.tar.gz 1018847 RMD160 0eabc391c89ba5f132811f803c4dfe53e6fe5812 SHA1 0ebf95734aa4f6f656c8b7e73e4cd411d6fd2870 SHA256 8e7992ae6391178768bb58c230424a430ed57693a3cc7c4c22001ddc682910ff
+EBUILD fox-4.0.4.ebuild 1373 RMD160 4d33339a5bbe926c5f4b2cd427621eb6c6056fad SHA1 bbbb178b57e400bc9d42f8dbea9c40a25ccca7e7 SHA256 d63a976dffaf701db9c7b48bde6efdd00738d0a3dd9c2056812187d4c867e9c4
+EBUILD fox-4.1.0.ebuild 1334 RMD160 e1c03022ec8ed3c134594e49116b9ef2af0c2d19 SHA1 d682f6b3d8366ec1db87ea6c957a18db6d2327d4 SHA256 e6233aaacebfd9c62cc797537062b76bafbf4ac7705279021aec5149f0dbf835
+MISC ChangeLog 346 RMD160 bf574dfda3242da520f587d10c1f9bb437074036 SHA1 bd1822703d2ce1b0ac929ac26de5a37af863907d SHA256 07115e849028f419895fc98f22359cf53103c6e256ba587ab7c6adbd0bb7a3d6
diff --git a/sci-libs/fox/files/4.0.4-install-customizations.patch b/sci-libs/fox/files/4.0.4-install-customizations.patch
new file mode 100644
index 000000000..0ea77314c
--- /dev/null
+++ b/sci-libs/fox/files/4.0.4-install-customizations.patch
@@ -0,0 +1,27 @@
+diff -Naur tmp-old/Makefile tmp-new/Makefile
+--- Makefile 2009-03-07 22:44:12.000000000 +0000
++++ Makefile 2009-03-07 22:42:59.000000000 +0000
+@@ -9,9 +9,9 @@
+ mkdir -p objs/lib objs/finclude
+ #
+ install: objsdir $(BUILD_TARGETS)
+- $(MKDIR_P) $(install_prefix)/lib $(install_prefix)/finclude $(install_prefix)/bin
++ $(MKDIR_P) $(install_prefix)/lib $(install_prefix)/lib/finclude $(install_prefix)/bin
+ $(INSTALL) objs/lib/* $(install_prefix)/lib
+- $(INSTALL) -m 644 objs/finclude/* $(install_prefix)/finclude
++ $(INSTALL) -m 644 objs/finclude/* $(install_prefix)/lib/finclude
+ $(INSTALL) FoX-config $(install_prefix)/bin
+ #
+ examples_build:
+diff -Naur tmp-old/arch.make.in tmp-new/arch.make.in
+--- arch.make.in 2009-03-07 22:44:19.000000000 +0000
++++ arch.make.in 2009-03-07 22:43:07.000000000 +0000
+@@ -5,7 +5,7 @@
+
+ VPATH=@VPATH@
+ compile_prefix=@OBJSDIR@
+-install_prefix=@prefix@
++install_prefix=$(DESTDIR)/@prefix@
+ LIB_DIR=$(compile_prefix)/lib
+ MOD_DIR=$(compile_prefix)/finclude
+
diff --git a/sci-libs/fox/fox-4.0.4.ebuild b/sci-libs/fox/fox-4.0.4.ebuild
new file mode 100644
index 000000000..0bb430de1
--- /dev/null
+++ b/sci-libs/fox/fox-4.0.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils
+
+MY_PN="FoX"
+MY_P="${MY_PN}-${PV}"
+DIRV="${PV/%[0-9]/X}"
+
+DESCRIPTION="A library designed to allow the easy use of XML from Fortran"
+HOMEPAGE="http://www1.gly.bris.ac.uk/~walker/FoX/"
+SRC_URI="http://www1.gly.bris.ac.uk/~walker/FoX/source/${MY_PN}-${DIRV}/${MY_P}-full.tar.gz"
+LICENSE="BSD ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc dom fast sax wcml wxml"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/4.0.4-install-customizations.patch
+}
+
+src_configure() {
+ econf --prefix=/usr \
+ $(use_enable debug) \
+ $(use_enable dom) \
+ $(use_enable fast) \
+ $(use_enable sax) \
+ $(use_enable wcml) \
+ $(use_enable wxml) \
+ FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_test() {
+ emake -j1 check || die "make check failed"
+ einfo "Please look at the last few RESULT lines for a summary."
+}
+
+src_install() {
+ sed -i -e's%^comp_prefix=.*$%comp_prefix=/usr%' \
+ -e's%comp_prefix/finclude%comp_prefix/lib/finclude%' \
+ FoX-config
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ dodoc README.FoX.txt Changelog LICENSE || die "dodoc failed"
+ if use doc; then
+ dohtml -r DoX/ || die "installing the HTML docs failed"
+ fi
+}
diff --git a/sci-libs/fox/fox-4.1.0.ebuild b/sci-libs/fox/fox-4.1.0.ebuild
new file mode 100644
index 000000000..ea50a3411
--- /dev/null
+++ b/sci-libs/fox/fox-4.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils
+
+MY_PN="FoX"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library designed to allow the easy use of XML from Fortran"
+HOMEPAGE="http://www1.gly.bris.ac.uk/~walker/FoX/"
+SRC_URI="http://www1.gly.bris.ac.uk/~walker/FoX/source/${MY_P}-full.tar.gz"
+LICENSE="BSD ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc dom fast sax wcml wxml"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/4.0.4-install-customizations.patch
+}
+
+src_configure() {
+ econf --prefix=/usr \
+ $(use_enable debug) \
+ $(use_enable dom) \
+ $(use_enable fast) \
+ $(use_enable sax) \
+ $(use_enable wcml) \
+ $(use_enable wxml) \
+ FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_test() {
+ emake -j1 check || die "make check failed"
+ einfo "Please look at the last few RESULT lines for a summary."
+}
+
+src_install() {
+ sed -i -e's%^comp_prefix=.*$%comp_prefix=/usr%' \
+ -e's%comp_prefix/finclude%comp_prefix/lib/finclude%' \
+ FoX-config
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ dodoc README.FoX.txt Changelog LICENSE || die "dodoc failed"
+ if use doc; then
+ dohtml -r DoX/ || die "installing the HTML docs failed"
+ fi
+}