aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRongcui Dong <carldong76@gmail.com>2014-08-30 10:44:20 -0400
committerRongcui Dong <carldong76@gmail.com>2014-08-30 10:44:20 -0400
commit9efdacf717aed763c7f505459d84cc5e3858219c (patch)
tree53f4716499503d659877a1ca205810c6422704ea /sci-libs/gmsh
parentMerge branch 'master' of ssh://github.com/gentoo-science/sci (diff)
downloadsci-9efdacf717aed763c7f505459d84cc5e3858219c.tar.gz
sci-9efdacf717aed763c7f505459d84cc5e3858219c.tar.bz2
sci-9efdacf717aed763c7f505459d84cc5e3858219c.zip
sci-libs/gmsh: Updated sci-libs/gmsh to 2.8.5 and EAPI to 5
Package-Manager: portage-2.3.6-r9
Diffstat (limited to 'sci-libs/gmsh')
-rw-r--r--sci-libs/gmsh/ChangeLog11
-rw-r--r--sci-libs/gmsh/Manifest1
-rw-r--r--sci-libs/gmsh/gmsh-2.5.0-r2.ebuild (renamed from sci-libs/gmsh/gmsh-2.5.0-r1.ebuild)6
-rw-r--r--sci-libs/gmsh/gmsh-2.8.5.ebuild (renamed from sci-libs/gmsh/gmsh-2.5.0.ebuild)8
-rw-r--r--sci-libs/gmsh/gmsh-9999.ebuild2
5 files changed, 20 insertions, 8 deletions
diff --git a/sci-libs/gmsh/ChangeLog b/sci-libs/gmsh/ChangeLog
index 359eac0e7..70af5550b 100644
--- a/sci-libs/gmsh/ChangeLog
+++ b/sci-libs/gmsh/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for sci-libs/gmsh
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*gmsh-2.5.0-r2 (30 Aug 2014)
+*gmsh-2.8.5 (30 Aug 2014)
+
+ 30 Aug 2014; Rongcui Dong <carldong76@gmail.com> +gmsh-2.5.0-r2.ebuild,
+ +gmsh-2.8.5.ebuild, -gmsh-2.5.0-r1.ebuild, -gmsh-2.5.0.ebuild,
+ gmsh-9999.ebuild:
+ sci-libs/gmsh: Updated sci-libs/gmsh to 2.8.5 and EAPI to 5
+
22 Feb 2013; Justin Lecher <jlec@gentoo.org> gmsh-2.5.0.ebuild, metadata.xml:
Add missing dep on virtual/pkgconfig
@@ -103,4 +111,3 @@
26 Aug 2008; Oliver Borm (boroli) <oli.borm@web.de> +gmsh-2.2.3.ebuild,
+files/gmsh-2.2.3-metis.patch, +files/gmsh-2.2.3.patch, +metadata.xml:
Ebuild for gmsh as reported in bug 195980.
-
diff --git a/sci-libs/gmsh/Manifest b/sci-libs/gmsh/Manifest
index 30b416bc7..51e909b64 100644
--- a/sci-libs/gmsh/Manifest
+++ b/sci-libs/gmsh/Manifest
@@ -1 +1,2 @@
DIST gmsh-2.5.0-source.tgz 3642009 SHA256 db1d3b92e56a85be9ec1c020aa2c705ccf5b7f0d00fa0f29b50efc73b378debc SHA512 6f3f7f25eca4ee140e1dd19dbc5b7dfbeaa3a44da24a6534235fbb81d672bbfa20f33f06a1bc74be92e0a29967d4cdf73525626b04105f8c5bb9c6060a74a622 WHIRLPOOL 4664ce36ed62624d8ad809e825a41ffcabdb2a98e82e078e8fe9662466d96272072ea5cbae821e3768974d3b9c615a36e11e9402bfc08a8282a1316d5464c557
+DIST gmsh-2.8.5-source.tgz 8665258 SHA256 0ea2fdbcc9ba44c90e03dbc553e7f0ddb2f9044173ac34db123db4fe65af3130 SHA512 2dc132551ce6b3aebb84367c2e1f65448ef68398021a799070413bb2b4616bca2b25b61166ed9977775e8c5c27ba802b4119c240c89b69817336b8a5241171a7 WHIRLPOOL f1538f611938b593a33189ece14fd804fd0c54ffe90677af1244688ad25f088541371b236fac8d375f345124bdaf3f2368529ee4c5d24e6bbe136ec94b5fb285
diff --git a/sci-libs/gmsh/gmsh-2.5.0-r1.ebuild b/sci-libs/gmsh/gmsh-2.5.0-r2.ebuild
index c4373616c..25db3df25 100644
--- a/sci-libs/gmsh/gmsh-2.5.0-r1.ebuild
+++ b/sci-libs/gmsh/gmsh-2.5.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
inherit cmake-utils fortran-2 toolchain-funcs
@@ -35,6 +35,10 @@ RDEPEND="
taucs? ( sci-libs/taucs )
"
+REQUIRED_USE="
+ taucs? ( || ( metis ) )
+ "
+
DEPEND="${RDEPEND}
doc? ( virtual/latex-base )"
diff --git a/sci-libs/gmsh/gmsh-2.5.0.ebuild b/sci-libs/gmsh/gmsh-2.8.5.ebuild
index e42959ac3..326a6f785 100644
--- a/sci-libs/gmsh/gmsh-2.5.0.ebuild
+++ b/sci-libs/gmsh/gmsh-2.8.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
inherit cmake-utils flag-o-matic fortran-2 toolchain-funcs
@@ -32,9 +32,9 @@ RDEPEND="
mpi? ( virtual/mpi[cxx] )
taucs? ( sci-libs/taucs )"
-# taucs needs metis enabled.
-# Wait for the REQUIRED_USE syntax in EAPI4.
-# http://www.gentoo.org/proj/en/council/meeting-logs/20101130-summary.txt
+REQUIRED_USE="
+ taucs? ( || ( metis ) )
+ "
DEPEND="${RDEPEND}
virtual/pkgconfig
diff --git a/sci-libs/gmsh/gmsh-9999.ebuild b/sci-libs/gmsh/gmsh-9999.ebuild
index 7796179f2..fb1573768 100644
--- a/sci-libs/gmsh/gmsh-9999.ebuild
+++ b/sci-libs/gmsh/gmsh-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
inherit cmake-utils flag-o-matic fortran-2 subversion toolchain-funcs