aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-05 21:11:29 +0100
committerJustin Lecher <jlec@gentoo.org>2013-11-05 21:11:29 +0100
commit5bd5d2a8e1fac662ae677c25234cb906938ec638 (patch)
treefa8069bc418165d0ff1420b8a2ad64eb3e18c1af /sci-libs/libxc
parentdev-java/scirenderer update dependency version (diff)
downloadsci-5bd5d2a8e1fac662ae677c25234cb906938ec638.tar.gz
sci-5bd5d2a8e1fac662ae677c25234cb906938ec638.tar.bz2
sci-5bd5d2a8e1fac662ae677c25234cb906938ec638.zip
sci-libs/libxc: Version BUmp; fix compilation problem with gcc-4.8, #488470
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-libs/libxc')
-rw-r--r--sci-libs/libxc/ChangeLog6
-rw-r--r--sci-libs/libxc/Manifest1
-rw-r--r--sci-libs/libxc/libxc-2.0.1.ebuild17
-rw-r--r--sci-libs/libxc/libxc-2.0.2.ebuild59
-rw-r--r--sci-libs/libxc/metadata.xml2
5 files changed, 78 insertions, 7 deletions
diff --git a/sci-libs/libxc/ChangeLog b/sci-libs/libxc/ChangeLog
index 4bf38b928..acf8a85cd 100644
--- a/sci-libs/libxc/ChangeLog
+++ b/sci-libs/libxc/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*libxc-2.0.2 (05 Nov 2013)
+
+ 05 Nov 2013; Justin Lecher <jlec@gentoo.org> libxc-2.0.1.ebuild,
+ +libxc-2.0.2.ebuild, metadata.xml:
+ Version BUmp; fix compilation problem with gcc-4.8, #488470
+
*libxc-2.0.1 (17 Jun 2013)
*libxc-1.2.0-r1 (17 Jun 2013)
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
index a85ebc898..4f27e6cf9 100644
--- a/sci-libs/libxc/Manifest
+++ b/sci-libs/libxc/Manifest
@@ -1,2 +1,3 @@
DIST libxc-1.2.0.tar.gz 895527 SHA256 ee441c3cde2e2bd87828186aa17f6e4438d17b38634c5d29bb12d3b7554461fb SHA512 3ac0fd07e40db4feb0f0a4ebe1358fdd4de0fff21f6dd369895c658a14cd3bafedbbc374b89f68320401dfcfe16a6230e05403fdaccfcbebb98349ca06593125 WHIRLPOOL 66439bf65a656567c0e52a4ee20b206658a9185bdbd3e045daca00bf01ba0199ccbedea3e5034cf90fbc36dbc04d9666cde8bde46e2577ffd160800f1718bd2a
DIST libxc-2.0.1.tar.gz 1062846 SHA256 c332f08648ec2bc7ccce83e45a84776215aa5dfebc64fae2a23f2ac546d41ea4 SHA512 c7d87134911fdfd91d985397a3fa990a63cc05d0752f0e2522e41dae0c2f39c43f9bd87ee6eb1972ab92b1aedeefad55a33ad84b1c66032e61ca03c87db02c5b WHIRLPOOL 16a5b999bb60177fde1371421f41f35736af4fcf8df123318ea438ffd34f487dcbadc95124ab9cf6ab2edeadd7983c56e0ca9d84bf528254de1f2a003addd402
+DIST libxc-2.0.2.tar.gz 1060884 SHA256 402b0528a04d55294925558d80d03fff0f95defa3f4a6f8041d0d26857da1de5 SHA512 38e987127f312846649936c22b6f92e8f3242fd6052d132a94ba06a1e466009949dd5a50474d36944267354a9491df5cf6ee051f77deccf2ff9c99cb48e38e51 WHIRLPOOL 7566146db6799bd0d7516ed166f18b3ac43372ef2350c26f1f3e5259a02ae32bd10f3c0fd98ba49f1a66c5ec0b081f7a04f2484ada2891bccfe8b692e717da4a
diff --git a/sci-libs/libxc/libxc-2.0.1.ebuild b/sci-libs/libxc/libxc-2.0.1.ebuild
index 47b17a3da..13b5dc617 100644
--- a/sci-libs/libxc/libxc-2.0.1.ebuild
+++ b/sci-libs/libxc/libxc-2.0.1.ebuild
@@ -4,7 +4,9 @@
EAPI=5
-inherit autotools-utils fortran-2 multilib
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils flag-o-matic fortran-2 multilib
MY_P=${P//_/-}
@@ -25,12 +27,15 @@ pkg_setup() {
use fortran && fortran-2_pkg_setup
}
+src_prepare() {
+ sed \
+ -e "s:${PN}.f90:${PN}.F90:g" \
+ -i src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
src_configure() {
- local myeconfargs=(
- $(use_enable fortran)
- FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}} -fPIC"
- CFLAGS="${CFLAGS} -fPIC"
- )
+ local myeconfargs=( $(use_enable fortran) )
autotools-utils_src_configure
}
diff --git a/sci-libs/libxc/libxc-2.0.2.ebuild b/sci-libs/libxc/libxc-2.0.2.ebuild
new file mode 100644
index 000000000..13b5dc617
--- /dev/null
+++ b/sci-libs/libxc/libxc-2.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils flag-o-matic fortran-2 multilib
+
+MY_P=${P//_/-}
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
+SRC_URI="http://www.tddft.org/programs/octopus/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="fortran static-libs -test"
+
+S="${WORKDIR}"/${MY_P}
+
+MAKEOPTS+=" -j1"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed \
+ -e "s:${PN}.f90:${PN}.F90:g" \
+ -i src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( $(use_enable fortran) )
+ autotools-utils_src_configure
+}
+
+## Upstream recommends not running the test suite because it requires
+## human expert interpretation to determine whether output is an error or
+## expected under certain circumstances. Nevertheless, experts might want the option.
+# The autotools src_test function modified not to die. Runs emake check in build directory.
+src_test() {
+ debug-print-function ${FUNCNAME} "$@"
+
+ _check_build_dir
+ pushd "${BUILD_DIR}" > /dev/null || die
+ make check || ewarn "Make check failed. See above for details."
+ einfo "emake check done"
+ popd > /dev/null || die
+}
+
+src_install() {
+ autotools-utils_src_install
+
+}
diff --git a/sci-libs/libxc/metadata.xml b/sci-libs/libxc/metadata.xml
index b229aec85..897aa2e6b 100644
--- a/sci-libs/libxc/metadata.xml
+++ b/sci-libs/libxc/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
+ <herd>sci</herd>
</pkgmetadata>