aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2012-04-23 10:52:11 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2012-04-23 10:52:11 +0200
commit7c943367898b61e43ce4b16410662346d6efb8c9 (patch)
treefff0f39ce16e784d515bda8dfdfa3afd20c09cc5 /sci-libs/libxc
parentMinor improvements related to sci-libs/fox. (diff)
downloadsci-7c943367898b61e43ce4b16410662346d6efb8c9.tar.gz
sci-7c943367898b61e43ce4b16410662346d6efb8c9.tar.bz2
sci-7c943367898b61e43ce4b16410662346d6efb8c9.zip
sci-libs/libxc version bumped to 1.2.0.
Diffstat (limited to 'sci-libs/libxc')
-rw-r--r--sci-libs/libxc/ChangeLog5
-rw-r--r--sci-libs/libxc/libxc-1.2.0.ebuild53
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/libxc/ChangeLog b/sci-libs/libxc/ChangeLog
index db01b2c75..aa79aef28 100644
--- a/sci-libs/libxc/ChangeLog
+++ b/sci-libs/libxc/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*libxc-1.2.0 (23 Apr 2012)
+
+ 23 Apr 2012; Honza Macháček <Hloupy.Honza@centrum.cz> +libxc-1.2.0.ebuild:
+ Version bump to 1.2.0.
+
09 Feb 2012; Justin Lecher <jlec@gentoo.org> -libxc-1.0.ebuild,
-libxc-1.1.0.ebuild, libxc-1.1.0-r1.ebuild, libxc-9999.ebuild, metadata.xml:
Moved to autotools-utils, some more sanity
diff --git a/sci-libs/libxc/libxc-1.2.0.ebuild b/sci-libs/libxc/libxc-1.2.0.ebuild
new file mode 100644
index 000000000..982be1053
--- /dev/null
+++ b/sci-libs/libxc/libxc-1.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools-utils fortran-2 multilib
+
+MY_P=${P//_/-}
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
+SRC_URI="http://www.tddft.org/programs/octopus/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fortran static-libs"
+
+S="${WORKDIR}"/${MY_P}
+
+MAKEOPTS+=" -j1"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran)
+ FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}} -fPIC"
+ CFLAGS="${CFLAGS} -fPIC"
+ )
+ autotools-utils_src_configure
+}
+
+## Upstream recommends not running the test suite because it requires
+## human expert interpretation to determine whether output is an error or
+## expected under certain circumstances.
+# src_test() { :; }
+
+src_install() {
+ autotools-utils_src_install
+
+ if use fortran; then
+ # argument for this: --with-moduledir from etsf_io/bigdft
+ insinto /usr/$(get_libdir)/finclude
+ pushd "${AUTOTOOLS_BUILD_DIR}"/src >/dev/null
+ doins *.mod || die
+ rm -f "${D}"/usr/include/*.mod || die
+ popd >/dev/null
+ fi
+}