aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2013-06-18 15:54:29 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2013-06-18 15:54:29 +0200
commit83a6f8e906f3701f214c034c05285f7106cc5413 (patch)
tree48cdc250b87bae94a68d1f444ec97da057623f9c /sci-libs/libxc
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
parentsci-chemistry/modeller: Fix broken symlink, #473680 (diff)
downloadsci-83a6f8e906f3701f214c034c05285f7106cc5413.tar.gz
sci-83a6f8e906f3701f214c034c05285f7106cc5413.tar.bz2
sci-83a6f8e906f3701f214c034c05285f7106cc5413.zip
The dependency of several packages on sci-libs/libxc modified to reflect correctly the recent change in the upgrade of sci-physics/abinit & friends.
Diffstat (limited to 'sci-libs/libxc')
-rw-r--r--sci-libs/libxc/Manifest2
-rw-r--r--sci-libs/libxc/libxc-9999.ebuild27
2 files changed, 18 insertions, 11 deletions
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
index fa863cf20..a85ebc898 100644
--- a/sci-libs/libxc/Manifest
+++ b/sci-libs/libxc/Manifest
@@ -1,2 +1,2 @@
-DIST libxc-1.1.0.tar.gz 543168 SHA256 b75fb2a73a9e2d75e250cc77b71d5485c8e9b11c3b25c91899c366e217283c57 SHA512 a5ed3a4a7a7abaa11321fe877d01ff00132eab976205213e578cd57fbd2073eea00ce3a3afc188e30ebbd31deb32468c4472313df9992e8d9e3148e6f619936b WHIRLPOOL 8ff70acb2ee65b3373942b71e350fe146f1c205aa4c09dbb22adc04227ba6888482ce412b3e843a9402efd51f9cf6f478f9c65b97305b2035185e59b35484d9f
DIST libxc-1.2.0.tar.gz 895527 SHA256 ee441c3cde2e2bd87828186aa17f6e4438d17b38634c5d29bb12d3b7554461fb SHA512 3ac0fd07e40db4feb0f0a4ebe1358fdd4de0fff21f6dd369895c658a14cd3bafedbbc374b89f68320401dfcfe16a6230e05403fdaccfcbebb98349ca06593125 WHIRLPOOL 66439bf65a656567c0e52a4ee20b206658a9185bdbd3e045daca00bf01ba0199ccbedea3e5034cf90fbc36dbc04d9666cde8bde46e2577ffd160800f1718bd2a
+DIST libxc-2.0.1.tar.gz 1062846 SHA256 c332f08648ec2bc7ccce83e45a84776215aa5dfebc64fae2a23f2ac546d41ea4 SHA512 c7d87134911fdfd91d985397a3fa990a63cc05d0752f0e2522e41dae0c2f39c43f9bd87ee6eb1972ab92b1aedeefad55a33ad84b1c66032e61ca03c87db02c5b WHIRLPOOL 16a5b999bb60177fde1371421f41f35736af4fcf8df123318ea438ffd34f487dcbadc95124ab9cf6ab2edeadd7983c56e0ca9d84bf528254de1f2a003addd402
diff --git a/sci-libs/libxc/libxc-9999.ebuild b/sci-libs/libxc/libxc-9999.ebuild
index baf29d429..2432915ed 100644
--- a/sci-libs/libxc/libxc-9999.ebuild
+++ b/sci-libs/libxc/libxc-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
inherit autotools-utils fortran-2 multilib subversion
@@ -14,7 +14,7 @@ ESVN_BOOTSTRAP="eautoreconf -i"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="fortran static-libs"
+IUSE="fortran static-libs -test"
MAKEOPTS+=" -j1"
@@ -31,14 +31,21 @@ src_configure() {
autotools-utils_src_configure
}
+## Upstream recommends not running the test suite because it requires
+## human expert interpretation to determine whether output is an error or
+## expected under certain circumstances. Nevertheless, experts might want the option.
+# The autotools src_test function modified not to die. Runs emake check in build directory.
+src_test() {
+ debug-print-function ${FUNCNAME} "$@"
+
+ _check_build_dir
+ pushd "${BUILD_DIR}" > /dev/null || die
+ make check || ewarn "Make check failed. See above for details."
+ einfo "emake check done"
+ popd > /dev/null || die
+}
+
src_install() {
autotools-utils_src_install
- if use fortran; then
- insinto /usr/$(get_libdir)/finclude
- pushd "${AUTOTOOLS_BUILD_DIR}"/src >/dev/null
- doins *.mod || die
- rm -f "${D}"/usr/include/*.mod || die
- popd >/dev/null
- fi
}