aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-01-17 21:32:46 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-01-17 21:32:46 +0100
commitefc2eb0676beb78de534707937ce2085e0471281 (patch)
treea5d0c37cce5d8763478c30d2a078a4d45a437f7c /sci-libs/libxc
parentA FoX ebuild for sci-physics/abinit (diff)
downloadsci-efc2eb0676beb78de534707937ce2085e0471281.tar.gz
sci-efc2eb0676beb78de534707937ce2085e0471281.tar.bz2
sci-efc2eb0676beb78de534707937ce2085e0471281.zip
A libxc ebuild for sci-physics/abinit
Diffstat (limited to 'sci-libs/libxc')
-rw-r--r--sci-libs/libxc/ChangeLog11
-rw-r--r--sci-libs/libxc/Manifest4
-rw-r--r--sci-libs/libxc/libxc-1.0.ebuild54
-rw-r--r--sci-libs/libxc/libxc-9999.ebuild46
4 files changed, 115 insertions, 0 deletions
diff --git a/sci-libs/libxc/ChangeLog b/sci-libs/libxc/ChangeLog
new file mode 100644
index 000000000..09d066bed
--- /dev/null
+++ b/sci-libs/libxc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/libxc
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*libxc-9999 (17 Jan 2011)
+*libxc-1.0 (17 Jan 2011)
+
+ 17 Jan 2011; Honza Macháček <Hloupy.Honza@centrum.cz> +libxc-1.0.ebuild,
+ +libxc-9999.ebuild:
+ A libxc ebuild for sci-physics/abinit
+
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
new file mode 100644
index 000000000..60176742a
--- /dev/null
+++ b/sci-libs/libxc/Manifest
@@ -0,0 +1,4 @@
+DIST libxc-1.0.tar.gz 502757 RMD160 0e48a6ab484d1c9f6e305dfc9c860e46c01aa330 SHA1 48a54c718bfb8784bf5e6aadf82d62ffb70bc5a2 SHA256 890544853fc8ff81d895fc973b5f1ed293f957b035301aad2d6caea1ce1efdaa
+EBUILD libxc-1.0.ebuild 1255 RMD160 b5c3b28845f9b518c1eea6f1995984f66801e4f1 SHA1 e39d5334025af49c20e3d522db4e1742adb1d988 SHA256 ee96bb47b1655837202f5a856f3fad99c1141a8025c0a810a5f1b22aa57e8528
+EBUILD libxc-9999.ebuild 991 RMD160 e901d55d4b2c31d4ad8ece88aea75e97f684e966 SHA1 f83a7c5f5932873ba1a4674f8cb96f6258b52254 SHA256 f39d9b3e7eca682b9f648f5a55725e0fa08cf8d28ff5e80620c6dbeaecfcd43d
+MISC ChangeLog 307 RMD160 a331fd2e22a7440110c3043157221616815e7d8f SHA1 e8dcf7e64956a3133de72bbbcf9d97123ecd7a86 SHA256 d7d8494a901e301039eed38ee601808a6750860bcb9af5c94ac9f40c16123888
diff --git a/sci-libs/libxc/libxc-1.0.ebuild b/sci-libs/libxc/libxc-1.0.ebuild
new file mode 100644
index 000000000..6a3f194cb
--- /dev/null
+++ b/sci-libs/libxc/libxc-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit fortran multilib
+
+MY_P=${P//_/-}
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
+SRC_URI="http://www.tddft.org/programs/octopus/down.php?file=${PN}/${MY_P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fortran"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+MAKEOPTS="-j1"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use fortran ; then
+ FORTRAN="gfortran ifc g77 pgf77 pgf90"
+ fortran_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ "$(use_enable fortran)" \
+ FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}"
+}
+
+## Upstream recommends not running the test suite because it requires
+## human expert interpretation to determine whether output is an error or
+## expected under certain circumstances.
+# src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog AUTHORS || die
+
+ if use fortran; then
+ # argument for this: --with-moduledir from etsf_io/bigdft
+ insinto /usr/$(get_libdir)/finclude
+ pushd src >/dev/null
+ doins *.mod || die
+ rm -f "${D}"/usr/include/*.mod || die
+ popd >/dev/null
+ fi
+}
diff --git a/sci-libs/libxc/libxc-9999.ebuild b/sci-libs/libxc/libxc-9999.ebuild
new file mode 100644
index 000000000..ba15e67dd
--- /dev/null
+++ b/sci-libs/libxc/libxc-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit fortran eutils multilib toolchain-funcs flag-o-matic autotools subversion
+
+DESCRIPTION="The ETSF library of exchange-correlation functionals"
+HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
+ESVN_REPO_URI="http://www.tddft.org/svn/octopus/trunk/${PN}/"
+ESVN_BOOTSTRAP="eautoreconf -i"
+
+LICENSE="LGPL"
+SLOT="0"
+IUSE="fortran debug"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use fortran ; then
+ FORTRAN="gfortran ifc g77 pgf77 pgf90"
+ fortran_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf "$(use_enable fortran)" || die "econf failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README NEWS ChangeLog AUTHORS || die "dodoc failed"
+
+ if use fortran; then
+ insinto /usr/$(get_libdir)/finclude
+ cd src
+ doins *.mod
+ fi
+}