aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-07-29 01:36:43 +0200
committerHorea Christian <h.chr@mail.ru>2013-07-29 01:36:43 +0200
commit2f499f1f7c4e945f6639a9a7950cd6055c66dedf (patch)
tree242927b976e842dd5479761a9c936b933cb6e8f2 /sci-libs/nipy
parentChanged comment text, nipy instead of scikits_learn (diff)
downloadsci-2f499f1f7c4e945f6639a9a7950cd6055c66dedf.tar.gz
sci-2f499f1f7c4e945f6639a9a7950cd6055c66dedf.tar.bz2
sci-2f499f1f7c4e945f6639a9a7950cd6055c66dedf.zip
Updated nipy 0.3.0 ebuild to match the 9999 fix
Deleted some useless comment lines
Diffstat (limited to 'sci-libs/nipy')
-rw-r--r--sci-libs/nipy/nipy-0.3.0.ebuild17
-rw-r--r--sci-libs/nipy/nipy-9999.ebuild2
2 files changed, 12 insertions, 7 deletions
diff --git a/sci-libs/nipy/nipy-0.3.0.ebuild b/sci-libs/nipy/nipy-0.3.0.ebuild
index ebb9b63d5..6dc62788b 100644
--- a/sci-libs/nipy/nipy-0.3.0.ebuild
+++ b/sci-libs/nipy/nipy-0.3.0.ebuild
@@ -4,9 +4,10 @@
EAPI="5"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+DISTUTILS_NO_PARALLEL_BUILD=true
-inherit distutils-r1 eutils
+inherit distutils-r1 eutils multilib flag-o-matic
MY_P="nipy-${PV}"
@@ -26,6 +27,12 @@ RDEPEND="
DEPEND="
"
-python_install_all() {
- distutils-r1_python_install_all
-}
+python_prepare_all() {
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+} \ No newline at end of file
diff --git a/sci-libs/nipy/nipy-9999.ebuild b/sci-libs/nipy/nipy-9999.ebuild
index 31d75efde..6c3d7d758 100644
--- a/sci-libs/nipy/nipy-9999.ebuild
+++ b/sci-libs/nipy/nipy-9999.ebuild
@@ -4,8 +4,6 @@
EAPI=5
-# pyamg missing py3 support
-# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
DISTUTILS_NO_PARALLEL_BUILD=true