aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2015-11-10 01:46:45 +0100
committerHorea Christian <h.chr@mail.ru>2015-11-10 01:46:45 +0100
commite3c66a03567514092b9e5adec59ce9335adc1416 (patch)
treefd0cd46556fba732ac11e83c0da16cb6dee483e6 /sci-libs/nipype
parentdev-python/qtconsole: Resort order of qt supporting libs (diff)
downloadsci-e3c66a03567514092b9e5adec59ce9335adc1416.tar.gz
sci-e3c66a03567514092b9e5adec59ce9335adc1416.tar.bz2
sci-e3c66a03567514092b9e5adec59ce9335adc1416.zip
sci-libs/nipype: new versioned version
Package-Manager: portage-2.2.23
Diffstat (limited to 'sci-libs/nipype')
-rw-r--r--sci-libs/nipype/ChangeLog5
-rw-r--r--sci-libs/nipype/Manifest1
-rw-r--r--sci-libs/nipype/nipype-0.11.0.ebuild35
3 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/nipype/ChangeLog b/sci-libs/nipype/ChangeLog
index 1cc3228be..755a95f45 100644
--- a/sci-libs/nipype/ChangeLog
+++ b/sci-libs/nipype/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*nipype-0.11.0 (10 Nov 2015)
+
+ 10 Nov 2015; Horea Christian <h.chr@mail.ru> +nipype-0.11.0.ebuild:
+ sci-libs/nipype: new versioned version
+
27 Jul 2015; <chymera@gentoo.org> nipype-9999.ebuild:
setting USE requirement before inherit
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
new file mode 100644
index 000000000..fbf9682c7
--- /dev/null
+++ b/sci-libs/nipype/Manifest
@@ -0,0 +1 @@
+DIST nipype-0.11.0.tar.gz 2837853 SHA256 b1a69fbda7ce044ec24c2536f5733dfc251d16b4a713cab65f893d7e3357b437 SHA512 2b54cb5e57081b49565644a02d319477ecddb41ce6a6689c7f72f5381850afee2ce18ea4d0097ef0cb150fdff4980e1fc6a9c04d9a37610b65179727e8d8a82f WHIRLPOOL a406e44b13df4a90557f745753c19ee949b3267cf68245fb4ab3d23300e39aa481a36c47b690cf40681a1f1c4ffe772b88f36c71827debc23526604333683539
diff --git a/sci-libs/nipype/nipype-0.11.0.ebuild b/sci-libs/nipype/nipype-0.11.0.ebuild
new file mode 100644
index 000000000..7751c6c71
--- /dev/null
+++ b/sci-libs/nipype/nipype-0.11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# pyamg missing py3 support
+# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/0.11.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]"
+RDEPEND="
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}