aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Arteaga <andyspiros@gmail.com>2012-05-07 16:50:00 +0200
committerAndrea Arteaga <andyspiros@gmail.com>2012-05-07 16:50:00 +0200
commit0f442720e6c4ddbb83bb36ff05159aaf9d43325a (patch)
treea23897bb7bc284fc9f31ac33e3f677bd7987e03d /sci-libs/openblas
parentsync with gx86 (diff)
downloadsci-0f442720e6c4ddbb83bb36ff05159aaf9d43325a.tar.gz
sci-0f442720e6c4ddbb83bb36ff05159aaf9d43325a.tar.bz2
sci-0f442720e6c4ddbb83bb36ff05159aaf9d43325a.zip
[sci-libs/openblas] Version bump.
Diffstat (limited to 'sci-libs/openblas')
-rw-r--r--sci-libs/openblas/ChangeLog5
-rw-r--r--sci-libs/openblas/Manifest1
-rw-r--r--sci-libs/openblas/openblas-0.1.1.ebuild120
3 files changed, 126 insertions, 0 deletions
diff --git a/sci-libs/openblas/ChangeLog b/sci-libs/openblas/ChangeLog
index 6c0b9a90f..2aa621443 100644
--- a/sci-libs/openblas/ChangeLog
+++ b/sci-libs/openblas/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*openblas-0.1.1 (07 May 2012)
+ 07 May 2012; Andrea Arteaga <andyspiros@gmail.com>
+ +openblas-0.1.1.ebuild:
+ Version bump
+
*openblas-0.1 (23 Mar 2012)
23 Mar 2012; Andrea Arteaga <andyspiros@gmail.com>
+openblas-0.1.ebuild:
diff --git a/sci-libs/openblas/Manifest b/sci-libs/openblas/Manifest
index 9c2795391..0a204833b 100644
--- a/sci-libs/openblas/Manifest
+++ b/sci-libs/openblas/Manifest
@@ -1 +1,2 @@
+DIST openblas-0.1.1.tbz2 1657574 SHA256 0ab5f5b2ef7f3754977abf38686d8597a1296e91a27553867ece78357c453668 SHA512 834f1a2cfa03bafe484f59d6a7eea845f22210cacac52c605f09a5c939395f153e9213dc8f3abfccd133fb2efaeaf69d5053ad5cd90703a8eefd2877d4288981 WHIRLPOOL 1a2e4fe4616f9af453e1cbfaddfe103c7f73373d831f8a0dfc367c67c8d162ffbe911aa4a4f0ed26b2b44fb1e777ef6bddb1b785b4e8f879b7255a629d00b6c0
DIST openblas-0.1.tbz2 1638384 SHA256 c20d5cca807d1a47c76bd6ed4d05e4f265584bb7ac5b777245616738c8388097 SHA512 76ee80bb85c066ddd175776cdd6d7a4707d0dad34028cf656a51ffac88289b28ddcfd96aff4915c412a457225ed14ab9c0bfea7cc64c0c80227157a404d20d21 WHIRLPOOL bb3b3fa522ad0e82c9ab4ee1bd4370ab96010537a1b3656c5d7eb87b6ac8aed15cdf4e9f107f47a4bcd6036e6dcb88f4d87318f805c895d5f92cd8a98a5f0cfe
diff --git a/sci-libs/openblas/openblas-0.1.1.ebuild b/sci-libs/openblas/openblas-0.1.1.ebuild
new file mode 100644
index 000000000..09b6092dd
--- /dev/null
+++ b/sci-libs/openblas/openblas-0.1.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs alternatives-2 multilib
+
+DESCRIPTION="Optimized BLAS library based on GotoBLAS2"
+HOMEPAGE="http://xianyi.github.com/OpenBLAS/"
+SRC_URI="http://soc.dev.gentoo.org/~spiros/repository/${P}.tbz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos ~ppc-macos ~x64-macos"
+
+IUSE="+incblas int64 dynamic openmp static-libs threads"
+
+RDEPEND="virtual/fortran"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-{sharedlibs-0.1,aliasing}.patch
+ # respect LDFLAGS
+ sed -i -e '/^LDFLAGS\s*=/d' Makefile.* || die
+ # respect CFLAGS only if dynamic flag not enabled
+ if ! use dynamic; then
+ sed -i \
+ -e "/^COMMON_OPT/s/-O2/${CFLAGS}/" \
+ Makefile.rule || die
+ fi
+ # fix executable stacks
+ local i
+ for i in $(find . -name \*.S); do
+ cat >> ${i} <<-EOF
+ #if defined(__ELF__)
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+}
+
+src_configure() {
+ local use_openmp=$(use openmp && echo 1)
+ use threads && use openmp && use_openmp="" && \
+ einfo "openmp and threads enabled: using threads"
+ sed -i \
+ -e "s:^#\s*\(NO_LAPACK\)\s*=.*:\1=1:" \
+ -e "s:^#\s*\(CC\)\s*=.*:\1=$(tc-getCC):" \
+ -e "s:^#\s*\(FC\)\s*=.*:\1=$(tc-getFC):" \
+ -e "s:^#\s*\(USE_THREAD\)\s*=.*:\1=$(use threads && echo 1 || echo 0):" \
+ -e "s:^#\s*\(USE_OPENMP\)\s*=.*:\1=${use_openmp}:" \
+ -e "s:^#\s*\(DYNAMIC_ARCH\)\s*=.*:\1=$(use dynamic && echo 1):" \
+ -e "s:^#\s*\(INTERFACE64\)\s*=.*:\1=$(use int64 && echo 1):" \
+ -e "s:^#\s*\(NO_CBLAS\)\s*=.*:\1=$(use incblas || echo 1):" \
+ Makefile.rule || die
+}
+
+src_compile() {
+ mkdir solibs
+ emake libs shared && mv *$(get_libname) solibs/
+ use static-libs && emake clean && emake libs NEED_PIC=
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ local profname=${PN} threads
+ use int64 && profname=${profname}-int64
+ if use threads; then
+ threads="-pthread"
+ profname=${profname}-threads
+ elif use openmp; then
+ profname=${profname}-openmp
+ fi
+
+ dolib.so solibs/lib*$(get_libname)
+ use static-libs && dolib.a lib*.a
+
+ # create pkg-config file and associated eselect file
+ cat <<-EOF > ${profname}.pc
+ prefix=${EPREFIX}/usr
+ libdir=\${prefix}/$(get_libdir)
+ includedir=\${prefix}/include
+ Name: ${PN}
+ Description: ${DESCRIPTION}
+ Version: ${PV}
+ URL: ${HOMEPAGE}
+ Libs: -L\${libdir} -lopenblas -lm ${threads}
+ EOF
+
+ alternatives_for blas ${profname} 0 \
+ "/usr/$(get_libdir)/pkgconfig/blas.pc" "${profname}.pc"
+
+ if use incblas; then
+ echo >> ${profname}.pc "Cflags: -I\${includedir}/${PN}"
+ insinto /usr/include/${PN}
+ doins cblas.h common*.h config.h param.h
+ alternatives_for cblas ${profname} 0 \
+ "/usr/$(get_libdir)/pkgconfig/cblas.pc" "${profname}.pc" \
+ "/usr/include/cblas.h" "${PN}/cblas.h"
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${profname}.pc
+ dodoc GotoBLAS_{01Readme,03FAQ,04FAQ,05LargePage,06WeirdPerformance}.txt
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ cd "${ED}"/usr/$(get_libdir)
+ for d in *.dylib ; do
+ ebegin "correcting install_name of ${d}"
+ install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${d}" "${d}"
+ eend $?
+ done
+ fi
+}