aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-30 15:54:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-30 15:54:01 +0100
commit4b1645fe18182c7a4311be24baffc31ad0947f7d (patch)
tree49954a9d4b9e4e42fcc2c22aad520f809ea4cdb2 /sci-libs/tmglib
parentsci-libs/lapacke-reference: Version Bump (diff)
downloadsci-4b1645fe18182c7a4311be24baffc31ad0947f7d.tar.gz
sci-4b1645fe18182c7a4311be24baffc31ad0947f7d.tar.bz2
sci-4b1645fe18182c7a4311be24baffc31ad0947f7d.zip
Update to new cmake-utils API
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/tmglib')
-rw-r--r--sci-libs/tmglib/tmglib-3.5.0.ebuild6
-rw-r--r--sci-libs/tmglib/tmglib-3.6.0.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sci-libs/tmglib/tmglib-3.5.0.ebuild b/sci-libs/tmglib/tmglib-3.5.0.ebuild
index 36512bdf7..3548eb7c2 100644
--- a/sci-libs/tmglib/tmglib-3.5.0.ebuild
+++ b/sci-libs/tmglib/tmglib-3.5.0.ebuild
@@ -49,18 +49,18 @@ src_configure() {
tmg_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
+ BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
-DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
}
src_compile() {
cmake-utils_src_compile -C TESTING/MATGEN
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
+ use static-libs && BUILD_DIR="${WORKDIR}/${PN}_static" \
cmake-utils_src_compile -C TESTING/MATGEN
}
src_install() {
cmake-utils_src_install -C TESTING/MATGEN
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
+ use static-libs && BUILD_DIR="${WORKDIR}/${PN}_static" \
cmake-utils_src_install -C TESTING/MATGEN
}
diff --git a/sci-libs/tmglib/tmglib-3.6.0.ebuild b/sci-libs/tmglib/tmglib-3.6.0.ebuild
index 4f66f4503..f403c5370 100644
--- a/sci-libs/tmglib/tmglib-3.6.0.ebuild
+++ b/sci-libs/tmglib/tmglib-3.6.0.ebuild
@@ -49,18 +49,18 @@ src_configure() {
tmg_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
+ BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
-DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
}
src_compile() {
cmake-utils_src_compile -C TESTING/MATGEN
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
+ use static-libs && BUILD_DIR="${WORKDIR}/${PN}_static" \
cmake-utils_src_compile -C TESTING/MATGEN
}
src_install() {
cmake-utils_src_install -C TESTING/MATGEN
use static-libs \
- && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install -C TESTING/MATGEN
+ && BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install -C TESTING/MATGEN
}