aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2014-12-10 10:47:03 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2014-12-10 10:47:03 +0100
commit5387d8ed4e684d7921d7e52e9fc8768a1bbec640 (patch)
tree3d6281368bef78a867af1983317a47d23b022f75 /sci-libs/wannier90
parentMerge branch 'master' of ssh://github.com/gentoo-science/sci (diff)
downloadsci-5387d8ed4e684d7921d7e52e9fc8768a1bbec640.tar.gz
sci-5387d8ed4e684d7921d7e52e9fc8768a1bbec640.tar.bz2
sci-5387d8ed4e684d7921d7e52e9fc8768a1bbec640.zip
Bumped sci-libs/wannier90 to version 2.0. Preserved 1.2 version until compatibility of 2.0 with sci-physics/abinit is verified, stepped up to 1.2-r3 purging forgotten LIBDIR/finclude.
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-libs/wannier90')
-rw-r--r--sci-libs/wannier90/ChangeLog9
-rw-r--r--sci-libs/wannier90/Manifest1
-rw-r--r--sci-libs/wannier90/wannier90-1.2-r3.ebuild (renamed from sci-libs/wannier90/wannier90-1.2-r2.ebuild)2
-rw-r--r--sci-libs/wannier90/wannier90-2.0.0.ebuild65
4 files changed, 76 insertions, 1 deletions
diff --git a/sci-libs/wannier90/ChangeLog b/sci-libs/wannier90/ChangeLog
index 4311efb5c..c778e5eee 100644
--- a/sci-libs/wannier90/ChangeLog
+++ b/sci-libs/wannier90/ChangeLog
@@ -2,6 +2,15 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*wannier90-2.0.0 (10 Dec 2014)
+*wannier90-1.2-r3 (10 Dec 2014)
+
+ 10 Dec 2014; Honza Macháček <Hloupy.Honza@centrum.cz>
+ -wannier90-1.2-r2.ebuild, +wannier90-1.2-r3.ebuild, +wannier90-2.0.0.ebuild:
+ Version bump to sci-libs/wannier90-2.0. Preserved 1.2 version until
+ compatibility of 2.0 with sci-physics/abinit is verified, stepped up to
+ 1.2-r3 purging forgotten LIBDIR/finclude.
+
15 Nov 2014; Christoph Junghans <ottxor@gentoo.org> wannier90-1.2-r2.ebuild:
fixed latex dep
diff --git a/sci-libs/wannier90/Manifest b/sci-libs/wannier90/Manifest
index e9e7a8f2d..8a8829898 100644
--- a/sci-libs/wannier90/Manifest
+++ b/sci-libs/wannier90/Manifest
@@ -1 +1,2 @@
DIST wannier90-1.2.tar.gz 5643731 SHA256 a76f88eef01c5a40aaa2c74ee393ede8a57bd9085f6b7f2ab656b50c1a30ece4 SHA512 323d078d0cdeeb361389600c39501410ca0da2879e8ba7d3262b49a76167e5385c09484eed47607d83feb68c9f16cfb6cdcebe89f7846157e0c71a8598238853 WHIRLPOOL 7e3288a85188d4661467d293d4a57973e926bf5a3b5736f83ed51e16a0fc4155ecc86e4e6dc6638b8a4d6373ca718ffd341cc11bde466d0166c1e591a9ac33c5
+DIST wannier90-2.0.0.tar.gz 46152394 SHA256 e419a721541c16e89de66b8eefe2c41042dd7ff78a1fe8d61554a00efe79382a SHA512 87d9ae7f0f0343e188711bc2cea2124ef1e13482e87a0c2a7d250c36cabeb9d0a6da9eba92781763a0e65665c48f9bae4cd12f5f5390f87a7e8f15c508411efc WHIRLPOOL d9bafcab196735d182518dd71fc4ae7618a4cfdd9e21e450f4d5b17b288bb1ae43c93bdde5d3fca0b180377881f7443b00cc7dc989edf5609133271d01c00bab
diff --git a/sci-libs/wannier90/wannier90-1.2-r2.ebuild b/sci-libs/wannier90/wannier90-1.2-r3.ebuild
index 63967705d..e8e79df9f 100644
--- a/sci-libs/wannier90/wannier90-1.2-r2.ebuild
+++ b/sci-libs/wannier90/wannier90-1.2-r3.ebuild
@@ -61,7 +61,7 @@ src_install() {
dobin wannier90.x
use perl && dobin utility/kmesh.pl
dolib.a libwannier.a
- insinto /usr/$(get_libdir)/finclude
+ insinto /usr/include
doins src/*.mod
if use examples; then
insinto /usr/share/${PN}
diff --git a/sci-libs/wannier90/wannier90-2.0.0.ebuild b/sci-libs/wannier90/wannier90-2.0.0.ebuild
new file mode 100644
index 000000000..1c00f9fd8
--- /dev/null
+++ b/sci-libs/wannier90/wannier90-2.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="Calculates maximally localized Wannier functions (MLWFs)"
+HOMEPAGE="http://www.wannier.org/"
+SRC_URI="http://wannier.org/code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc examples perl test"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+src_configure() {
+ cat <<- EOF >> "${S}"/make.sys
+ F90 = $(tc-getFC)
+ FCOPTS = ${FCFLAGS:- ${FFLAGS:- -O2}}
+ LDOPTS = ${LDFLAGS}
+ LIBS = $($(tc-getPKG_CONFIG) --libs blas lapack)
+ EOF
+}
+
+src_compile() {
+ emake -j1 wannier
+ emake -j1 lib
+ if use doc; then
+ VARTEXFONTS="${T}/fonts"
+ emake -j1 doc
+ fi
+}
+
+src_test() {
+ einfo "Compare the 'Standard' and 'Current' outputs of this test."
+ pushd tests
+ emake test
+ cat wantest.log
+}
+
+src_install() {
+ dobin wannier90.x
+ use perl && dobin utility/kmesh.pl
+ dolib.a libwannier.a
+ insinto /usr/include
+ doins src/obj/*.mod
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+ use doc && dodoc doc/*.pdf
+ dodoc README README.install CHANGE.log
+}