aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-04-07 01:22:14 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-04-07 01:22:14 +0200
commit05fb7f5eb4908941e81559aacac3c6797263c43b (patch)
tree3c31e6d9bea570bd903c09f07a6c3b693c4579b7 /sci-libs
parentsci-chemistry/modeller: Version bump (diff)
downloadsci-05fb7f5eb4908941e81559aacac3c6797263c43b.tar.gz
sci-05fb7f5eb4908941e81559aacac3c6797263c43b.tar.bz2
sci-05fb7f5eb4908941e81559aacac3c6797263c43b.zip
sci-libs/tensorflow: version bump
The ebuild does not compile for me still, it needs more work. Credits: Rok Kralj Closes: https://github.com/gentoo/sci/issues/857 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow/Manifest1
-rw-r--r--sci-libs/tensorflow/tensorflow-1.5.0.ebuild19
-rw-r--r--sci-libs/tensorflow/tensorflow-1.7.0.ebuild43
3 files changed, 61 insertions, 2 deletions
diff --git a/sci-libs/tensorflow/Manifest b/sci-libs/tensorflow/Manifest
index 3d31b86e0..31a4accb4 100644
--- a/sci-libs/tensorflow/Manifest
+++ b/sci-libs/tensorflow/Manifest
@@ -1,2 +1,3 @@
DIST tensorflow-1.0.1.tar.gz 10919903 BLAKE2B 1ce4de131436b2b7fec909251a8b4c03d872920cbe788eb9914c5670803fc0baf8462d1d6498c9ee3ef4e941bd0286bebda44745ac49d8044627a93fac28c746 SHA512 49f22cd6baca8770401aacd870b30b33f4eaa576c9f2d3caae0a00225d40041352d5300cb3dc5ec90ec9f0e8865eb542a7d3d6a0f39ceb6d0f2606cc4725f0a7
DIST tensorflow-1.5.0.tar.gz 19155285 BLAKE2B 32000e583b85f195fc62acafc22254d8806b26a59f06b024c2be98c0a3b5770cbfc60f73957a3f11cdbf7488b8891978f73a22b6d642fdd763ecd95f18e38d65 SHA512 63240d72b9946db29279800b1081adc4cc08b6cd7dc35155a529cc335bfc1dd16fb525fb6047f6cc0dcec547a54e7e100698a176ee93f5633965cfab2a8ad9eb
+DIST tensorflow-1.7.0.tar.gz 21202162 BLAKE2B 28ce2e002aa6c44681aa4f55af6172b05a3b4f797b5093db23ab67adf06170df9d1a9c64705613e17e6c1ff0f95fe9a1115464c697585ab83fef7baee5ea0985 SHA512 68fffad324be7f6e3726ea539670572729bd72c7dc935edfdb31771f821f1a8fe90c3d7c293969f660a25e5fd76249cc9b74c5f8511c7bd3e2189d3328044f29
diff --git a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
index b2e2e596a..0dae0c1d0 100644
--- a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
@@ -17,12 +17,27 @@ SLOT="0"
KEYWORDS=""
IUSE="cuda mpi"
+# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
+# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
+# version.
+# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
+# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
+# version.
DEPEND="dev-util/bazel
dev-python/wheel
dev-python/numpy
dev-libs/protobuf-c
- cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-7.0[profiler] >=dev-libs/cudnn-3 )
mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
-# TODO: seems it also support some MPI implementation
+# TODO: seems it also supports some MPI implementation
+
+src_configure(){
+ # there is no setup.py but there is configure
+ # https://www.tensorflow.org/install/install_sources
+ # https://www.tensorflow.org/install/install_linux#InstallingNativePip
+ #
+ # usage: configure.py [-h] [--workspace WORKSPACE]
+ ./configure || die
+}
diff --git a/sci-libs/tensorflow/tensorflow-1.7.0.ebuild b/sci-libs/tensorflow/tensorflow-1.7.0.ebuild
new file mode 100644
index 000000000..0dae0c1d0
--- /dev/null
+++ b/sci-libs/tensorflow/tensorflow-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Library for numerical computation using data flow graphs"
+HOMEPAGE="https://www.tensorflow.org
+ https://github.com/tensorflow/tensorflow"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="cuda mpi"
+
+# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
+# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
+# version.
+# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
+# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
+# version.
+DEPEND="dev-util/bazel
+ dev-python/wheel
+ dev-python/numpy
+ dev-libs/protobuf-c
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-7.0[profiler] >=dev-libs/cudnn-3 )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# TODO: seems it also supports some MPI implementation
+
+src_configure(){
+ # there is no setup.py but there is configure
+ # https://www.tensorflow.org/install/install_sources
+ # https://www.tensorflow.org/install/install_linux#InstallingNativePip
+ #
+ # usage: configure.py [-h] [--workspace WORKSPACE]
+ ./configure || die
+}