aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2016-06-12 22:18:50 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2016-06-12 22:18:50 +0300
commit129cc05301a4d485af937c113b3d9a41cb6110f4 (patch)
tree0c825f63c9a8f45aa795c431877e9e5341f1176e /sys-cluster
parentsys-cluster/lustre: Update patches (diff)
downloadsci-129cc05301a4d485af937c113b3d9a41cb6110f4.tar.gz
sci-129cc05301a4d485af937c113b3d9a41cb6110f4.tar.bz2
sci-129cc05301a4d485af937c113b3d9a41cb6110f4.zip
sys-cluster/lustre: Add ebuild for 2.8.0 tag
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lustre/Manifest1
-rw-r--r--sys-cluster/lustre/files/lustre-readline6.3_fix.patch13
-rw-r--r--sys-cluster/lustre/lustre-2.8.0.ebuild106
-rw-r--r--sys-cluster/lustre/lustre-9999.ebuild10
4 files changed, 109 insertions, 21 deletions
diff --git a/sys-cluster/lustre/Manifest b/sys-cluster/lustre/Manifest
deleted file mode 100644
index 7a3a720b2..000000000
--- a/sys-cluster/lustre/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST 0002-LU-3319-procfs-move-mdd-ofd-proc-handling-to-seq_fil.patch 69297 SHA256 943ddf700986f5942b33cac0e9f68b35847b3aa613dd08c44b9305c6d0350a6b SHA512 6b7826b993d77bfc9e865389e68fd38386b2657165540810d56f0eacb8ca8d5f182fad681c9ac75d2315cc9a30d7846b0047a368c671a551231645933c1fc8a7 WHIRLPOOL be85ff756cdd4c8a74d44167a656d6e67c7b00fe860f471ec750d2146b5fb69fc8a4bc00477b0eaa2de4adec7c623ea32e25e829d8e77923ac87e3e599f3df7c
diff --git a/sys-cluster/lustre/files/lustre-readline6.3_fix.patch b/sys-cluster/lustre/files/lustre-readline6.3_fix.patch
deleted file mode 100644
index 50384d682..000000000
--- a/sys-cluster/lustre/files/lustre-readline6.3_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/libcfs/libcfs/util/parser.c b/libcfs/libcfs/util/parser.c
-index f395fa3..3fc0373 100644
---- a/libcfs/libcfs/util/parser.c
-+++ b/libcfs/libcfs/util/parser.c
-@@ -308,7 +308,7 @@ int init_input()
- rl_deprep_term_function = (rl_voidfunc_t *)noop_fn;
- }
-
-- rl_attempted_completion_function = (CPPFunction *)command_completion;
-+ rl_attempted_completion_function = (rl_completion_func_t *)command_completion;
- rl_completion_entry_function = (void *)command_generator;
- #endif
- return interactive;
diff --git a/sys-cluster/lustre/lustre-2.8.0.ebuild b/sys-cluster/lustre/lustre-2.8.0.ebuild
new file mode 100644
index 000000000..59c8e550e
--- /dev/null
+++ b/sys-cluster/lustre/lustre-2.8.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.15"
+WANT_LIBTOOL="latest"
+
+if [[ $PV = *9999* ]]; then
+ KEYWORDS=""
+ EGIT_BRANCH="master"
+else
+ KEYWORDS="~amd64"
+ EGIT_TAG="${PV}"
+fi
+
+inherit git-r3 autotools linux-mod toolchain-funcs udev flag-o-matic
+
+DESCRIPTION="Lustre is a parallel distributed file system"
+HOMEPAGE="http://wiki.whamcloud.com/"
+SRC_URI=""
+EGIT_REPO_URI="git://git.whamcloud.com/fs/lustre-release.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+client +utils server liblustre readline tests tcpd +urandom"
+
+RDEPEND="
+ virtual/awk
+ readline? ( sys-libs/readline:0 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ server? (
+ >=sys-kernel/spl-0.6.1
+ >=sys-fs/zfs-kmod-0.6.1
+ sys-fs/zfs
+ )
+ "
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+
+pkg_setup() {
+ filter-mfpmath sse
+ filter-mfpmath i386
+ filter-flags -msse* -mavx* -mmmx -m3dnow
+ linux-mod_pkg_setup
+ ARCH="$(tc-arch-kernel)"
+ ABI="${KERNEL_ABI}"
+}
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+ # replace upstream autogen.sh by our src_prepare()
+ local DIRS="libcfs lnet lustre snmp"
+ local ACLOCAL_FLAGS
+ for dir in $DIRS ; do
+ ACLOCAL_FLAGS="$ACLOCAL_FLAGS -I $dir/autoconf"
+ done
+ _elibtoolize -q
+ eaclocal -I config $ACLOCAL_FLAGS
+ eautoheader
+ eautomake
+ eautoconf
+ # now walk in configure dirs
+ einfo "Reconfiguring source in libsysio"
+ cd libsysio
+ eaclocal
+ eautomake
+ eautoconf
+ cd ..
+}
+
+src_configure() {
+ local myconf
+ if use server; then
+ SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
+ myconf="${myconf} --with-spl=${EROOT}usr/src/${SPL_PATH} \
+ --with-spl-obj=${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
+ ZFS_PATH=$(basename $(echo "${EROOT}usr/src/zfs-"*)) \
+ myconf="${myconf} --with-zfs=${EROOT}usr/src/${ZFS_PATH} \
+ --with-zfs-obj=${EROOT}usr/src/${ZFS_PATH}/${KV_FULL}"
+ fi
+ econf \
+ ${myconf} \
+ --without-ldiskfs \
+ --disable-ldiskfs-build \
+ --with-linux="${KERNEL_DIR}" \
+ --with-linux-release="${KV_FULL}" \
+ $(use_enable client) \
+ $(use_enable utils) \
+ $(use_enable server) \
+ $(use_enable liblustre) \
+ $(use_enable readline) \
+ $(use_enable tcpd libwrap) \
+ $(use_enable urandom) \
+ $(use_enable tests)
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+}
diff --git a/sys-cluster/lustre/lustre-9999.ebuild b/sys-cluster/lustre/lustre-9999.ebuild
index 3c8af2d9b..59c8e550e 100644
--- a/sys-cluster/lustre/lustre-9999.ebuild
+++ b/sys-cluster/lustre/lustre-9999.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
WANT_AUTOCONF="2.5"
-WANT_AUTOMAKE="1.10"
+WANT_AUTOMAKE="1.15"
WANT_LIBTOOL="latest"
if [[ $PV = *9999* ]]; then
@@ -20,7 +20,7 @@ inherit git-r3 autotools linux-mod toolchain-funcs udev flag-o-matic
DESCRIPTION="Lustre is a parallel distributed file system"
HOMEPAGE="http://wiki.whamcloud.com/"
-SRC_URI="https://raw.githubusercontent.com/gentoo-science/sci/master/patches/0002-LU-3319-procfs-move-mdd-ofd-proc-handling-to-seq_fil.patch"
+SRC_URI=""
EGIT_REPO_URI="git://git.whamcloud.com/fs/lustre-release.git"
LICENSE="GPL-2"
@@ -40,10 +40,6 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/linux-sources"
-PATCHES=(
- "${FILESDIR}/lustre-readline6.3_fix.patch"
-)
-
pkg_setup() {
filter-mfpmath sse
filter-mfpmath i386