aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bigaouette <nbigaouette@gmail.com>2012-04-28 11:04:38 -0400
committerNicolas Bigaouette <nbigaouette@gmail.com>2012-04-28 11:06:45 -0400
commit05deda75a8f8db36c127d533d59990b384e27b73 (patch)
tree91ff3f6a941ea13461d472c7c3f97b06f3d4d72c /sys-devel
parentmask =sci-libs/mmdb-1.24.20111208, no pkg-confiles installed (diff)
downloadsci-05deda75a8f8db36c127d533d59990b384e27b73.tar.gz
sci-05deda75a8f8db36c127d533d59990b384e27b73.tar.bz2
sci-05deda75a8f8db36c127d533d59990b384e27b73.zip
New ebuild: AMD gDEBugger version 6.2.438, an OpenCL and OpenGL debugger and memory analyzer.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdebugger/Manifest3
-rw-r--r--sys-devel/gdebugger/gdebugger-6.2.438.ebuild68
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-devel/gdebugger/Manifest b/sys-devel/gdebugger/Manifest
new file mode 100644
index 000000000..18a6d1564
--- /dev/null
+++ b/sys-devel/gdebugger/Manifest
@@ -0,0 +1,3 @@
+DIST AMDgDEBugger6.2.438x86.tar.gz 26645419 RMD160 2737291e9d4d8e82b76a7a4057279f22f80c20f5 SHA1 818a707e047e96007fd1bb0777af35c2907bdd05 SHA256 659c544eaf80a9bd1e33aa685a30b5fff8cd75117fef45dd14008fb966e4edbb
+DIST AMDgDEBugger6.2.438x86_64.tar.gz 26814026 RMD160 5733180f7af66c099d955bd587a4d4bc1dc480e7 SHA1 8e069a09976d1136a45a25334c8c70e4261796f1 SHA256 78d67e68b441fea446d22bd49e192bd561973ce734589e05e0c610ba5870120c
+EBUILD gdebugger-6.2.438.ebuild 2097 RMD160 e02680a16eb0a03625dec7b23d9d4f054adf33b2 SHA1 d1a0aac15907b6bfbc8df7da9e3f6ef9aa0e25f1 SHA256 e0a4b84ade2368f62a7dc570421dd2274f0f1da1e086e478860d00d550c76ca0
diff --git a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
new file mode 100644
index 000000000..36375d387
--- /dev/null
+++ b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator
+
+My_PN="gDEBugger"
+My_PV=$(delete_all_version_separators)
+
+DESCRIPTION="OpenCL and OpenGL debugger and memory analyzer."
+HOMEPAGE="http://developer.amd.com/tools/gDEBugger/Pages/default.aspx"
+
+if [[ "${ARCH}" == "amd64" ]]; then
+ _arch="x86_64"
+elif [[ "${ARCH}" == "x86" ]]; then
+ _arch="x86"
+fi
+
+SRC_URI="
+ x86? ( http://developer.amd.com/Downloads/AMD${My_PN}${PV}x86.tar.gz )
+ amd64? ( http://developer.amd.com/Downloads/AMD${My_PN}${PV}x86_64.tar.gz )"
+
+LICENSE="${My_PN}"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/libstdc++"
+DEPEND="${RDEPEND} app-text/html2text"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}/${My_PN}${PV}-${_arch}"
+_destination=/opt/${My_PN}
+
+src_install() {
+ dodir /opt
+ dodir /usr/bin
+ dodir /usr/portage/licenses/
+ dodir /usr/share/applications
+
+ cd ..
+ cp -a ${S} ${D}${_destination}
+
+ # The included launcher gets the directory where it is being run; a symbolic
+ # link to it in /usr/bin thus cannot work. Instead, copy it to /usr/bin and
+ # remove the autodetection of the script's directory and hardcode it to ${_destination}.
+ # Then create a lowercase symbolic link to this new launcher.
+ cp ${D}${_destination}/${My_PN} ${D}/usr/bin/${My_PN}
+ sed "s|gDEBuggerBinariesDir=.*|gDEBuggerBinariesDir=\"${_destination}\"|g" -i ${D}/usr/bin/${My_PN}
+ dosym /usr/bin/${My_PN} /usr/bin/${PN}
+
+ html2text ${D}${_destination}/Legal/EndUserLicenseAgreement.htm > ${D}/usr/portage/licenses/${My_PN}.txt || die "Can't copy license"
+
+ echo "[Desktop Entry]
+Name=${My_PN}
+Exec=${_destination}/${My_PN}
+Type=Application
+GenericName=OpenCL/OpenGL debugger
+Terminal=false
+Icon=${My_PN}
+Caption=OpenCL/OpenGL debugger
+Categories=Application;Development;" > ${D}/usr/share/applications/${PN}.desktop || die "Can't create .desktop file"
+
+ insinto /usr/share/icons/hicolor/64x64/apps/
+ newins ${D}${_destination}/tutorial/images/applicationicon_64.png ${My_PN}.png
+}