aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost-compute/boost-compute-9999.ebuild')
-rw-r--r--dev-libs/boost-compute/boost-compute-9999.ebuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/dev-libs/boost-compute/boost-compute-9999.ebuild b/dev-libs/boost-compute/boost-compute-9999.ebuild
index 93b8d7b87..f4c20598b 100644
--- a/dev-libs/boost-compute/boost-compute-9999.ebuild
+++ b/dev-libs/boost-compute/boost-compute-9999.ebuild
@@ -4,29 +4,22 @@
EAPI=5
-inherit eutils cmake-utils
+inherit eutils cmake-utils git-r3
DESCRIPTION="A header-only C++ Computing Library for OpenCL"
HOMEPAGE="https://github.com/boostorg/compute"
+EGIT_REPO_URI="https://github.com/boostorg/compute.git git://github.com/boostorg/compute.git"
+KEYWORDS=""
LICENSE="Boost-1.0"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/boostorg/compute.git git://github.com/boostorg/compute.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/compute-${PV}"
-fi
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.4-Fix-install-destination-of-headers.patch
+)
RDEPEND="
dev-libs/boost
virtual/opencl
"
DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-0.4-CMakeLists.patch
-)