aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/specutils/specutils-9999.ebuild')
-rw-r--r--dev-python/specutils/specutils-9999.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/specutils/specutils-9999.ebuild b/dev-python/specutils/specutils-9999.ebuild
deleted file mode 100644
index e91b20477..000000000
--- a/dev-python/specutils/specutils-9999.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/astropy/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Affiliated package for 1D spectral operations"
-HOMEPAGE="https://github.com/astropy/specutils"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc"
-DOCS=( README.rst )
-
-RDEPEND="
- >=dev-python/astropy-0.4[${PYTHON_USEDEP}]
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- sed -e '/import ah_bootstrap/d' -i setup.py || die "Removing ah_bootstrap failed"
-}
-
-python_compile_all() {
- if use doc; then
- python_export_best
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}" || die
- "${EPYTHON}" -c "import ${PN}, sys;r = ${PN}.test(verbose=True);sys.exit(r)" \
- || die "tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}