aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/dipy/dipy-0.11.0.ebuild')
-rw-r--r--sci-biology/dipy/dipy-0.11.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/dipy/dipy-0.11.0.ebuild b/sci-biology/dipy/dipy-0.11.0.ebuild
new file mode 100644
index 000000000..9c97079ce
--- /dev/null
+++ b/sci-biology/dipy/dipy-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="computational neuroanatomy project focusing on diffusion MRI"
+HOMEPAGE="http://nipy.org/dipy"
+SRC_URI="https://github.com/nipy/dipy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ nosetests || die
+}
+