aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/psychopy/psychopy-1.83.03.ebuild')
-rw-r--r--sci-biology/psychopy/psychopy-1.83.03.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/psychopy/psychopy-1.83.03.ebuild b/sci-biology/psychopy/psychopy-1.83.03.ebuild
new file mode 100644
index 000000000..c22a36877
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-1.83.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils distutils-r1
+
+DESCRIPTION="Python experimental psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+SRC_URI="https://github.com/psychopy/psychopy/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[lapack,${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s scalable psychopy/monitors/psychopy-icon.svg psychopy.svg
+ make_desktop_entry psychopyApp.py PsychoPy psychopy
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}