aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mddnmr/mddnmr-2.7.ebuild')
-rw-r--r--sci-chemistry/mddnmr/mddnmr-2.7.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/sci-chemistry/mddnmr/mddnmr-2.7.ebuild b/sci-chemistry/mddnmr/mddnmr-2.7.ebuild
deleted file mode 100644
index 3ef7b2c02..000000000
--- a/sci-chemistry/mddnmr/mddnmr-2.7.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-MY_P="${PN}${PV}"
-
-DESCRIPTION="Program for processing of NUS multidimensional NMR spectra"
-HOMEPAGE="http://mddnmr.spektrino.com/"
-SRC_URI="${MY_P}.tgz"
-
-SLOT="0"
-KEYWORDS=""
-LICENSE="mddnmr"
-
-RESTRICT="fetch"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-shells/tcsh
- sci-chemistry/nmrpipe"
-DEPEND=""
-
-RESTRICT="mirror"
-
-S="${WORKDIR}"/${PN}
-
-QA_PREBUILT="opt/${PN}/.*"
-
-src_install() {
- exeinto /opt/${PN}/com
- doexe com/*
-
- exeinto /opt/${PN}/bin
- if use amd64; then
- doexe binXeonE5mkl/*
- elif use x86; then
- doexe binUbuntu32Static/*
- fi
-
- insinto /opt/${PN}/
- doins -r GUI
-
- cat >> "${T}"/qMDD <<- EOF
- #!${EPREFIX}/bin/csh
-
- setenv LD_LIBRARY_PATH $(grep LDPATH "${EPREFIX}"/etc/env.d/35intelsdp | sed 's:LDAPATH=::g')"
- setenv MDD_NMR "${EPREFIX}/opt/${PN}"
- setenv MDD_NMRbin "${EPREFIX}/opt/${PN}/bin/"
- set path=( . "\$MDD_NMRbin" "\${MDD_NMR}/com" \$path )
-
- csh "${EPREFIX}/opt/${PN}/GUI/qMDD"
- EOF
-
- dobin "${T}"/qMDD
-
- dodoc *pdf
-
- python_optimize "${ED}"
-}