aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/bids-validator/bids-validator-1.2.2.ebuild')
-rw-r--r--sci-libs/bids-validator/bids-validator-1.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/bids-validator/bids-validator-1.2.2.ebuild b/sci-libs/bids-validator/bids-validator-1.2.2.ebuild
new file mode 100644
index 000000000..d18403fcd
--- /dev/null
+++ b/sci-libs/bids-validator/bids-validator-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Validator for the Brain Imaging Data Structure"
+HOMEPAGE="https://github.com/bids-standard/bids-validator"
+SRC_URI="https://github.com/bids-standard/bids-validator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/grabbit[${PYTHON_USEDEP}]
+ dev-python/num2words[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P}/${PN}"