aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/clfft/clfft-2.12.2.ebuild')
-rw-r--r--sci-libs/clfft/clfft-2.12.2.ebuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/sci-libs/clfft/clfft-2.12.2.ebuild b/sci-libs/clfft/clfft-2.12.2.ebuild
index c008c602c..9cfbc7f8a 100644
--- a/sci-libs/clfft/clfft-2.12.2.ebuild
+++ b/sci-libs/clfft/clfft-2.12.2.ebuild
@@ -1,12 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit cmake-utils
+EAPI=7
MY_PN="clFFT"
+DOCS_BUILDER="doxygen"
+DOCS_DIR="../docs"
+DOCS_CONFIG_NAME="${MY_PN}.doxy"
+
+inherit cmake docs
+
DESCRIPTION="Library containing FFT functions written in OpenCL"
HOMEPAGE="https://github.com/clMathLibraries/clFFT"
SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -14,17 +18,17 @@ SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="callback_client +client examples test"
+IUSE="callback_client +client test"
RDEPEND="
- >=sys-devel/gcc-4.6:*
virtual/opencl
- dev-libs/boost"
+ dev-libs/boost
+"
DEPEND="${RDEPEND}"
-# test? (
-# dev-cpp/gtest
-# sci-libs/fftw:3.0
-# )"
+BDEPEND="test? (
+ dev-cpp/gtest
+ sci-libs/fftw:3.0
+)"
# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
# Therefore src_test() won't execute any test.
@@ -32,21 +36,17 @@ RESTRICT="test"
S="${WORKDIR}/${MY_PN}-${PV}/src"
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-}
-
src_configure() {
local mycmakeargs=(
-DBUILD_CALLBACK_CLIENT="$(usex callback_client)"
-DBUILD_CLIENT="$(usex client)"
- -DBUILD_SAMPLE="$(usex examples)"
-DBUILD_TEST="$(usex test)"
-DBoost_USE_STATIC_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_compile() {
+ docs_compile
+ cmake_src_compile
}