aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ensmallen/ensmallen-2.16.2.ebuild')
-rw-r--r--sci-libs/ensmallen/ensmallen-2.16.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/ensmallen/ensmallen-2.16.2.ebuild b/sci-libs/ensmallen/ensmallen-2.16.2.ebuild
new file mode 100644
index 000000000..bd1c0530b
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.16.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}