aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ipopt/ipopt-3.11.6.ebuild')
-rw-r--r--sci-libs/ipopt/ipopt-3.11.6.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/sci-libs/ipopt/ipopt-3.11.6.ebuild b/sci-libs/ipopt/ipopt-3.11.6.ebuild
deleted file mode 100644
index 9af85e1ef..000000000
--- a/sci-libs/ipopt/ipopt-3.11.6.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-AUTOTOOLS_IN_SOURCE_BUILD=yes
-FORTRAN_NEEDED="mumps"
-inherit eutils autotools-utils multilib toolchain-funcs fortran-2
-
-MYPN=Ipopt
-MYP=${MYPN}-${PV}
-
-DESCRIPTION="Interior-Point Optimizer for large-scale nonlinear optimization"
-HOMEPAGE="https://projects.coin-or.org/Ipopt/"
-SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYP}.tgz"
-
-LICENSE="EPL-1.0 hsl? ( HSL )"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples hsl lapack mpi mumps static-libs test"
-
-RDEPEND="
- virtual/blas
- hsl? ( sci-libs/coinhsl )
- lapack? ( virtual/lapack )
- mumps? ( sci-libs/mumps[mpi=] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
- test? ( sci-libs/coinor-sample sci-libs/mumps )"
-
-S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-
-src_prepare() {
- #epatch "${FILESDIR}"/${P}-mpi-header.patch
-
- # as-needed fix
- # hack to avoid eautoreconf (coinor has its own weird autotools)
- sed -i \
- -e 's:\(libipopt_la_LIBADD.*=.*\)$:\1 @IPOPTLIB_LIBS@:g' \
- src/Interfaces/Makefile.in || die
-
- if use mumps && ! use mpi; then
- ln -s "${EPREFIX}"/usr/include/mpiseq/mpi.h \
- src/Algorithm/LinearSolvers/
- elif use mpi; then
- export CXX=mpicxx FC=mpif77 F77=mpif77 CC=mpicc
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --with-blas-lib="$($(tc-getPKG_CONFIG) --libs blas)"
- $(use_with doc dot)
- )
-
- if use lapack; then
- myeconfargs+=( --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" )
- else
- myeconfargs+=( --without-lapack )
- fi
- if use mumps; then
- myeconfargs+=(
- --with-mumps-incdir="${EPREFIX}"/usr/include
- --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps" )
- else
- myeconfargs+=( --without-mumps )
- fi
- if use hsl; then
- myeconfargs+=(
- --with-hsl-incdir="${EPREFIX}"/usr/include
- --with-hsl-lib="$($(tc-getPKG_CONFIG) --libs coinhsl)" )
- else
- myeconfargs+=( --without-hsl )
- fi
- PKG_CONFIG_PATH+="${ED}"/usr/$(get_libdir)/pkgconfig \
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile all $(use doc && echo doxydoc)
-}
-
-src_test() {
- pushd "${BUILD_DIR}" > /dev/null || die
- emake test
- popd > /dev/null || die
-}
-
-src_install() {
- use doc && HTML_DOC=("${AUTOTOOLS_BUILD_DIR}/doxydocs/html/")
- autotools-utils_src_install
- # already installed
- rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}