aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pytorch/files/pytorch-1.4.0-sleef.patch')
-rw-r--r--sci-libs/pytorch/files/pytorch-1.4.0-sleef.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sci-libs/pytorch/files/pytorch-1.4.0-sleef.patch b/sci-libs/pytorch/files/pytorch-1.4.0-sleef.patch
new file mode 100644
index 000000000..222a0f73e
--- /dev/null
+++ b/sci-libs/pytorch/files/pytorch-1.4.0-sleef.patch
@@ -0,0 +1,15 @@
+Give the location of sleef.h.
+
+Reference: https://github.com/pytorch/pytorch/issues/26555
+Index: pytorch-1.4.0/caffe2/CMakeLists.txt
+===================================================================
+--- pytorch-1.4.0.orig/caffe2/CMakeLists.txt
++++ pytorch-1.4.0/caffe2/CMakeLists.txt
+@@ -1062,6 +1062,7 @@ if (BUILD_TEST)
+ add_executable(${test_name} "${test_src}")
+ target_link_libraries(${test_name} ${Caffe2_MAIN_LIBS} gtest_main)
+ target_include_directories(${test_name} PRIVATE $<INSTALL_INTERFACE:include>)
++ target_include_directories(${test_name} PRIVATE $<BUILD_INTERFACE:${CMAKE_BINARY_DIR}/include>)
+ target_include_directories(${test_name} PRIVATE ${Caffe2_CPU_INCLUDE})
+ add_test(NAME ${test_name} COMMAND $<TARGET_FILE:${test_name}>)
+ if (INSTALL_TEST)