aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/gasnet/gasnet-9999.ebuild')
-rw-r--r--sys-cluster/gasnet/gasnet-9999.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/sys-cluster/gasnet/gasnet-9999.ebuild b/sys-cluster/gasnet/gasnet-9999.ebuild
deleted file mode 100644
index dc60493f5..000000000
--- a/sys-cluster/gasnet/gasnet-9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit autotools git-r3
-
-MY_P="${PN^^[gasn]}-${PV}"
-DESCRIPTION="Networking middleware for partitioned global address space (PGAS) language"
-HOMEPAGE="http://gasnet.lbl.gov/"
-SRC_URI=""
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="mpi threads"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- echo
- elog "GASNet has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable threads pthreads)
- $(use_enable mpi)
- )
- econf ${myeconfargs[@]}
-}