aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/casperjs/casperjs-1.1_beta3.ebuild')
-rw-r--r--www-client/casperjs/casperjs-1.1_beta3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-client/casperjs/casperjs-1.1_beta3.ebuild b/www-client/casperjs/casperjs-1.1_beta3.ebuild
new file mode 100644
index 000000000..b4145b8df
--- /dev/null
+++ b/www-client/casperjs/casperjs-1.1_beta3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v3
+# $Id$
+
+EAPI=5
+
+MY_PV=${PV/_beta/-beta}
+
+DESCRIPTION="Navigation scripting & testing utility for PhantomJS and SlimerJS"
+HOMEPAGE="http://casperjs.org/"
+SRC_URI="https://github.com/n1k0/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="<www-client/phantomjs-2.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/${P}/
+ doins -r modules/
+ doins -r tests/
+ doins package.json
+
+ insinto /usr/share/${P}/bin
+ doins bin/bootstrap.js
+ doins bin/usage.txt
+
+ dobin bin/casperjs
+ dosym /usr/bin/casperjs ../share/${P}/bin/casperjs
+
+ dodoc CHANGELOG.md CONTRIBUTORS.md README.md
+}