summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-03-29 00:12:34 +0000
committerhasufell <julian.ospald@googlemail.com>2012-03-29 00:12:34 +0000
commit2cce2c030cc988a1abfb7354ba9e47434df44638 (patch)
treec1514a6b63722fc6435d9aad94baddb476bfc171
parentx11-misc/spacefm-trash-plugin: New Ebuild for bug 410083 thanks to xmw and fl... (diff)
downloadsunrise-reviewed-2cce2c030cc988a1abfb7354ba9e47434df44638.tar.gz
sunrise-reviewed-2cce2c030cc988a1abfb7354ba9e47434df44638.tar.bz2
sunrise-reviewed-2cce2c030cc988a1abfb7354ba9e47434df44638.zip
x11-misc/spacefm-httpshare-plugin: New Ebuild for bug 410083 thanks to xmw and floppym
svn path=/sunrise/; revision=12857
-rw-r--r--x11-misc/spacefm-httpshare-plugin/ChangeLog10
-rw-r--r--x11-misc/spacefm-httpshare-plugin/Manifest4
-rw-r--r--x11-misc/spacefm-httpshare-plugin/metadata.xml7
-rw-r--r--x11-misc/spacefm-httpshare-plugin/spacefm-httpshare-plugin-0.5.ebuild41
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/spacefm-httpshare-plugin/ChangeLog b/x11-misc/spacefm-httpshare-plugin/ChangeLog
new file mode 100644
index 000000000..d56011f14
--- /dev/null
+++ b/x11-misc/spacefm-httpshare-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/spacefm-httpshare-plugin
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*spacefm-httpshare-plugin-0.5 (29 Mar 2012)
+
+ 29 Mar 2012; hasufell <julian.ospald@googlemail.com>
+ +spacefm-httpshare-plugin-0.5.ebuild, +metadata.xml:
+ New Ebuild for bug 410083 thanks to xmw and floppym
+
diff --git a/x11-misc/spacefm-httpshare-plugin/Manifest b/x11-misc/spacefm-httpshare-plugin/Manifest
new file mode 100644
index 000000000..7b6a2efe7
--- /dev/null
+++ b/x11-misc/spacefm-httpshare-plugin/Manifest
@@ -0,0 +1,4 @@
+DIST Share_v0.5.spacefm-plugin.tar.gz 28219 RMD160 a21b8982e046479b9549e20ec6cafd7f029a78b3 SHA1 bd873b75a9a81e8f92b18724afc3e88ebbeb8ec0 SHA256 4b7580d1d9b7589e2eb41b57ffcf902283d2c2b22a444cd1013dc8463617330b
+EBUILD spacefm-httpshare-plugin-0.5.ebuild 1164 RMD160 4efec458b9ae0846134b6603bc47cd3f7af4ed84 SHA1 ab96ab6ef3653825da43161be70bdd6543896109 SHA256 e4744ae2aafa928f37fcd09c9a6c1a66499c43cc0db85eedbeeed4a194a82f49
+MISC ChangeLog 344 RMD160 410a71396355f4b8950965400321fa2115b6154c SHA1 c8be35eb3924ae04af838042365f6b2052e81ea8 SHA256 0f6cf580db59b3046f82ed1909ea6f9a029de13b71bb15090a96b2ff6dfe0da2
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/x11-misc/spacefm-httpshare-plugin/metadata.xml b/x11-misc/spacefm-httpshare-plugin/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/x11-misc/spacefm-httpshare-plugin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/spacefm-httpshare-plugin/spacefm-httpshare-plugin-0.5.ebuild b/x11-misc/spacefm-httpshare-plugin/spacefm-httpshare-plugin-0.5.ebuild
new file mode 100644
index 000000000..b87e3de10
--- /dev/null
+++ b/x11-misc/spacefm-httpshare-plugin/spacefm-httpshare-plugin-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Plugin to quickly share files/folders via http server"
+HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/share-via-http-server/share-via-http-server"
+SRC_URI="http://bashscripts.googlecode.com/files/Share_v${PV}.spacefm-plugin.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ x11-misc/spacefm"
+
+src_install() {
+ find -name COPYING -delete
+ insinto /usr/share/spacefm/plugins/httpshare
+ doins -r cstm_* plugin
+ insinto /usr/share/spacefm/plugin-files
+ doins "${DISTDIR}"/Share_v${PV}.spacefm-plugin.tar.gz
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "You might need to restart spacefm for the changes to take effect."
+ einfo ""
+ elog "If you want to add a plugin to a different menu via design-mode"
+ elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo ""
+ elog "If you have copied the plugin to a different menu using the"
+ elog "design mode you might want to remove it from there as well."
+ einfo ""
+}