summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2008-09-11 18:57:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2008-09-11 18:57:34 +0000
commit95355b9ce9afde7f43ea75802f917decb1209ce0 (patch)
treeb5a03fd3054539c3ba1b5312144c7e51c80c7dcb
parentapp-text/pastebin: Ebuild for Bug #235377, based on the one by cHoBi (diff)
downloadsunrise-95355b9ce9afde7f43ea75802f917decb1209ce0.tar.gz
sunrise-95355b9ce9afde7f43ea75802f917decb1209ce0.tar.bz2
sunrise-95355b9ce9afde7f43ea75802f917decb1209ce0.zip
net-misc/kanyremote: New Ebuild for bug #209689
svn path=/sunrise/; revision=7066
-rw-r--r--net-misc/kanyremote/ChangeLog8
-rw-r--r--net-misc/kanyremote/Manifest4
-rw-r--r--net-misc/kanyremote/kanyremote-5.2.1.ebuild35
-rw-r--r--net-misc/kanyremote/metadata.xml5
4 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/kanyremote/ChangeLog b/net-misc/kanyremote/ChangeLog
new file mode 100644
index 000000000..17cddb146
--- /dev/null
+++ b/net-misc/kanyremote/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/kanyremote
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 11 Sep 2008; Markos Chandras (hwoarang) <gentoo@silverarrow.gr>
+ +kanyremote-5.2.1.ebuild, +metadata.xml:
+ New Ebuild for bug #209689
+
diff --git a/net-misc/kanyremote/Manifest b/net-misc/kanyremote/Manifest
new file mode 100644
index 000000000..cbf52f490
--- /dev/null
+++ b/net-misc/kanyremote/Manifest
@@ -0,0 +1,4 @@
+DIST kanyremote-5.2.1.tar.gz 513673 RMD160 18f087e7b38076d481532f689049e17ad68a9f58 SHA1 f5956813c1e9644ff229c2f5993dd0c2d100184a SHA256 32fef488e9c8a1bec71e7cdbfe32b2cca5b0cf5f12099ef0d0e5d33f3cde9d59
+EBUILD kanyremote-5.2.1.ebuild 898 RMD160 bab1344befafd00a5358135f9e95895d816ba9c6 SHA1 dea243705e892ab2e12353318a0599a0ee2b92b4 SHA256 c7f31db90335d9ca2b94dc5ff2d1aae39ce6eb8cb5cc1dc30e8c77dc02e50018
+MISC ChangeLog 259 RMD160 a33a2035f7663d2e178383173554c762025837a6 SHA1 a98c068112bee0823fd1d8c21c2870e2e1c375de SHA256 803b89529dc978cac73f65c19e0182bdc6046fcd2db46589f6f3d55a05e6772f
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-misc/kanyremote/kanyremote-5.2.1.ebuild b/net-misc/kanyremote/kanyremote-5.2.1.ebuild
new file mode 100644
index 000000000..82957cd67
--- /dev/null
+++ b/net-misc/kanyremote/kanyremote-5.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=" >=net-misc/anyremote-4.4
+ >=dev-python/PyQt-3.17
+ >=dev-python/pykde-3.16 "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ make_desktop_entry ${PN} ${PN} ${PN}.png "Network;RemoteAccess"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if ! built_with_use net-misc/anyremote bluetooth ; then
+ echo
+ ewarn "If you want to use bluetooth with kanyremote, you need to "
+ ewarn "compile net-misc/anyremote with bluetooth use flag."
+ echo
+ fi
+}
+
diff --git a/net-misc/kanyremote/metadata.xml b/net-misc/kanyremote/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/net-misc/kanyremote/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>