summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuan Aguado (juantxorena) <juantxorena@gmail.com>2007-05-30 09:21:04 +0000
committerJuan Aguado (juantxorena) <juantxorena@gmail.com>2007-05-30 09:21:04 +0000
commitbd4ec17b68e00fa85fdf0658f043539d3c868e3f (patch)
tree9733fabc8ee6de9c99f1b4d5476a347f8d5249cd
parentmedia-sound/soundkonverter: Disable aac use flag properly (diff)
downloadsunrise-bd4ec17b68e00fa85fdf0658f043539d3c868e3f.tar.gz
sunrise-bd4ec17b68e00fa85fdf0658f043539d3c868e3f.tar.bz2
sunrise-bd4ec17b68e00fa85fdf0658f043539d3c868e3f.zip
media-sound/soundkonverter: Add timidity support, various fixes and cosmetics
svn path=/sunrise/; revision=3779
-rw-r--r--media-sound/soundkonverter/ChangeLog4
-rw-r--r--media-sound/soundkonverter/Manifest4
-rw-r--r--media-sound/soundkonverter/soundkonverter-0.3.3.ebuild50
3 files changed, 37 insertions, 21 deletions
diff --git a/media-sound/soundkonverter/ChangeLog b/media-sound/soundkonverter/ChangeLog
index 0143ba474..392c59fe6 100644
--- a/media-sound/soundkonverter/ChangeLog
+++ b/media-sound/soundkonverter/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 30 May 2007; Juan Aguado (juantxorena) <juantxorena666@gmail.com>
+ soundkonverter-0.3.3.ebuild:
+ Add timidity support, various fixes and cosmetics
+
30 May 2007; Jakub Moc <jakub@gentoo.org> soundkonverter-0.3.3.ebuild:
Disable aac use flag properly
diff --git a/media-sound/soundkonverter/Manifest b/media-sound/soundkonverter/Manifest
index 65657c861..262603801 100644
--- a/media-sound/soundkonverter/Manifest
+++ b/media-sound/soundkonverter/Manifest
@@ -1,4 +1,4 @@
DIST soundkonverter-0.3.3.tar.bz2 625291 RMD160 9abfce8df4e74d62a51a6c1a819a242b99f419bd SHA1 3d54797173b0431d649a6348b51cdfc4792561e9 SHA256 8fe9ce3657b7f4425c475df8bb0d8417b3fa48af246b109efbb819c49e2766ec
-EBUILD soundkonverter-0.3.3.ebuild 1136 RMD160 bc3357585b16800b224f340161906c8df9cff4ca SHA1 ded7c386181d64c9238958bae3184cd0c9162843 SHA256 4a607cc44615bdd3f8c8b2dd019f41c4098669fb6fa0a98732dbc43de7c49d34
-MISC ChangeLog 1004 RMD160 13257598ee797865cdabec496043d5b86b9811c9 SHA1 eda4522436fa7ad397207138a3cb732374311163 SHA256 d5257a3ca893d4f8c3fb0888160a7ac322c7d1c780d4329477dd8943a6fefe3d
+EBUILD soundkonverter-0.3.3.ebuild 1501 RMD160 f426a0c130f2e24abfe4e1e10081b76aeb5e9fe8 SHA1 c875973460843053175ea459ca6e44b38efb8afe SHA256 c4fd87149eedacbc421fd19be78d5cfcb0078157f16d7b3a0fe52995f5b7ae54
+MISC ChangeLog 1156 RMD160 f98a7f85680095b950ea799fd34975b3003b37a0 SHA1 08be1f7226f13051a5ee702e4b0fb88d720fbabb SHA256 959dce8ecb46d22aa4b410b39a8f3ed73abe123fd2dc1651c2283f4841ce36c6
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild b/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild
index 97cfcd052..df87ec899 100644
--- a/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild
+++ b/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild
@@ -1,43 +1,55 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 2003-2007 SabayonLinux
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit kde qt3
+inherit kde eutils qt3
-DESCRIPTION="a frontend to various audio converters for KDE"
+DESCRIPTION="SoundKonverter: a frontend to various audio converters for KDE"
HOMEPAGE="http://kde-apps.org/content/show.php?content=29024"
-SRC_URI="http://hessijames.googlepages.com/${P}.tar.bz2"
-
-LICENSE="GPL-2"
+SRC_URI="http://hessijames.googlepages.com/soundkonverter-${PV}.tar.bz2"
+LICENSE="GPL"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="arts kdeenablefinal"
+RESTRICT="nomirror"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="kdeenablefinal arts"
+
+# This line should be added to "DEPEND" when the aac-mp4v2 gets fixed (see
+# bug #107189):
+# aac? ( media-libs/libmp4v2 )
DEPEND=">=media-libs/taglib-1.4
>=media-sound/cdparanoia-3.9.8-r5
$(qt_min_version 3.3.4)"
-# aac? ( media-libs/libmp4v2 )"
RDEPEND="${DEPEND}"
need-kde 3.5
+# This line should be added to "local myconf" when the aac-mp4v2 gets fixed (see
+# bug #107189):
+# $(use_with aac mp4v2)
+
src_compile() {
- local myconf="$(use_enable kdeenablefinal final) $(use_with arts)"
- kde_src_compile || die "Compile error"
+ append-flags -fno-inline
+ local myconf="$(use_enable kdeenablefinal final)
+ $(use_with arts)"
+ kde_src_compile
}
src_install() {
kde_src_install || die "Installation failed"
- mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}
}
pkg_postinst() {
- echo
- elog "For AmaroK users there is a script included with this package."
- elog "You can enable it with the Script Manager tool in Amarok."
- elog "This program supports various encoders and codecs."
- elog "For example you might want to install lame, ffmpeg, vorbis, flac "
- elog "and/or musepack."
- echo
+ elog
+ elog " The audio USE flags are for your convience, but are not required."
+ elog " For AmaroK users there is a script included with this package."
+ elog " You can enable it with the Script Manager tool in Amarok."
+ elog " This program supports various encoders and codecs."
+ elog " For example you might want to install lame, ffmpeg, vorbis, flac,"
+ elog " timidity and/or musepack."
+ elog
}
+