summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2011-03-16 16:15:38 +0000
committerNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2011-03-16 16:15:38 +0000
commitcf0f0303ef5244392421c8ffc4fc426ad5a92072 (patch)
tree046c6fc7ed4a7e105792efe7c54f071d69eba34d
parentsci-chemistry/hoomd: new ebuild for bug 357021, thanks Tommy[D], mgorny and ... (diff)
downloadsunrise-cf0f0303ef5244392421c8ffc4fc426ad5a92072.tar.gz
sunrise-cf0f0303ef5244392421c8ffc4fc426ad5a92072.tar.bz2
sunrise-cf0f0303ef5244392421c8ffc4fc426ad5a92072.zip
gnome-extra/gloobus-preview: Fix ignoring CXXFLAGS (partially fixes portage-multilib support). Bump ebuild to EAPI=4 to please reavertm. Fix ebuild to use autotools-utils eclass properly.
(Portage version: 2.2.0_alpha26-r1/svn/Linux x86_64) svn path=/sunrise/; revision=11825
-rw-r--r--gnome-extra/gloobus-preview/ChangeLog8
-rw-r--r--gnome-extra/gloobus-preview/files/gloobus-preview-0.4.1-cxxflags.patch12
-rw-r--r--gnome-extra/gloobus-preview/gloobus-preview-0.4.1.ebuild21
3 files changed, 30 insertions, 11 deletions
diff --git a/gnome-extra/gloobus-preview/ChangeLog b/gnome-extra/gloobus-preview/ChangeLog
index 23298a7e4..c74defb51 100644
--- a/gnome-extra/gloobus-preview/ChangeLog
+++ b/gnome-extra/gloobus-preview/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for gnome-extra/gloobus-preview
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Mar 2011; Nathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>
+ gloobus-preview-0.4.1.ebuild, +files/gloobus-preview-0.4.1-cxxflags.patch:
+ Fix ignoring CXXFLAGS (partially fixes portage-multilib support). Bump
+ ebuild to EAPI=4 to please reavertm. Fix ebuild to use autotools-utils
+ eclass properly.
+
06 Dec 2010; Fabiano Francesconi (elbryan) <fabiano.francesconi@gmail.com>
gloobus-preview-0.4.1.ebuild:
Now using remove_libtool_files to remove libtool files, of course
diff --git a/gnome-extra/gloobus-preview/files/gloobus-preview-0.4.1-cxxflags.patch b/gnome-extra/gloobus-preview/files/gloobus-preview-0.4.1-cxxflags.patch
new file mode 100644
index 000000000..2dc56e20b
--- /dev/null
+++ b/gnome-extra/gloobus-preview/files/gloobus-preview-0.4.1-cxxflags.patch
@@ -0,0 +1,12 @@
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+Subject: Don't ignore CXXFLAGS, fixes portage-multilib support.
+
+--- a/src/Makefile.am 2009-09-10 08:01:00.000000000 -0400
++++ b/src/Makefile.am 2011-03-16 09:45:30.000000000 -0400
+@@ -1,6 +1,5 @@
+ SUBDIRS = plugin-comic plugin-folder plugin-icns plugin-gstreamer-audio plugin-gstreamer-video plugin-openoffice plugin-pdf plugin-pixbuf plugin-text plugin-ttf .
+
+-CXXFLAGS = -Wall -g #If -O2 iDocument threads don't work
+ #AM_CXXFLAGS = -Wall
+ AM_LDFLAGS = -rdynamic
+ AM_CPPFLAGS =$(CAIRO_CFLAGS) $(GTK_CFLAGS) $(LIBGNOMEUI_CFLAGS) $(PTHREAD_CFLAGS) $(GTKSOURCEVIEW_CFLAGS)
diff --git a/gnome-extra/gloobus-preview/gloobus-preview-0.4.1.ebuild b/gnome-extra/gloobus-preview/gloobus-preview-0.4.1.ebuild
index 13d7054d1..3132ed9df 100644
--- a/gnome-extra/gloobus-preview/gloobus-preview-0.4.1.ebuild
+++ b/gnome-extra/gloobus-preview/gloobus-preview-0.4.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=4
-inherit autotools-utils versionator
+inherit autotools autotools-utils eutils versionator
MY_PV=$(get_version_component_range 1-2)
@@ -26,15 +26,16 @@ DEPEND="app-text/poppler
x11-libs/gtksourceview:2.0"
RDEPEND="${DEPEND}"
-src_configure() {
- econf --disable-static
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cxxflags.patch
+ eautomake
}
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Remove useless .la files
- remove_libtool_files 'all'
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+ autotools-utils_src_configure
}
pkg_postinst() {