summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-07-04 13:42:38 +0000
committerMichał Górny <mgorny@gentoo.org>2010-07-04 13:42:38 +0000
commitdcbdda776daeffb9838155db4160d92550b7e266 (patch)
tree3d290e16e727b803854b34cd82bf1cb554c35271
parentapp-misc/cursetheweather: Keyworded ~amd64, restricted python3 (diff)
downloadsunrise-dcbdda776daeffb9838155db4160d92550b7e266.tar.gz
sunrise-dcbdda776daeffb9838155db4160d92550b7e266.tar.bz2
sunrise-dcbdda776daeffb9838155db4160d92550b7e266.zip
app-misc/cursetheweather: Support Python ABIs and fix the dependencies.
svn path=/sunrise/; revision=10884
-rw-r--r--app-misc/cursetheweather/ChangeLog4
-rw-r--r--app-misc/cursetheweather/Manifest4
-rw-r--r--app-misc/cursetheweather/cursetheweather-0.6.ebuild10
3 files changed, 12 insertions, 6 deletions
diff --git a/app-misc/cursetheweather/ChangeLog b/app-misc/cursetheweather/ChangeLog
index a0db7ac22..2a81c736b 100644
--- a/app-misc/cursetheweather/ChangeLog
+++ b/app-misc/cursetheweather/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Jul 2010; Michał Górny (sedzimir) <mgorny.3ehbo@mailnull.com>
+ cursetheweather-0.6.ebuild:
+ Support Python ABIs and fix the dependencies.
+
04 Jul 2010; Michael Weber (xmw) <gentoo@xmw.de>
cursetheweather-0.6.ebuild:
Keyworded ~amd64, restricted python3
diff --git a/app-misc/cursetheweather/Manifest b/app-misc/cursetheweather/Manifest
index 6d75413d3..c27d59177 100644
--- a/app-misc/cursetheweather/Manifest
+++ b/app-misc/cursetheweather/Manifest
@@ -1,4 +1,4 @@
DIST CurseTheWeather-0.6.tar.gz 12987 RMD160 04bf72da31227105f1221567d972b87fcf2c3811 SHA1 ab91f4dd3205f7186b70a47951387d66cac2f0e0 SHA256 29a2d545e4e51398d5cf28385912be5966c0c18292bb00c19d736fc518145389
-EBUILD cursetheweather-0.6.ebuild 570 RMD160 e61e0a088e3a1a00c6c583c8eb9368ca8b08387b SHA1 1d0abcd0fd5bbd28256dd64e84c109612bd5a9ad SHA256 faaea15d229e72d60af7e5ce7d6686073ed0cf6c62926ff20b0535bcd3ee1ef8
-MISC ChangeLog 610 RMD160 1944ba448075cfbe3f5c960a2f6518d7d733d907 SHA1 eb141c7e6f3384e8813ac8c35798e2dfd41a29cc SHA256 8a72a1a0a0bdb5e9567ae51b3a4466977c4f50d76c63ff7b48b37f261aa44652
+EBUILD cursetheweather-0.6.ebuild 602 RMD160 bd3c909f35bf8802c330882a6ef499c1835da6f0 SHA1 996f1d6757e52315bad23dbd9394311af6c9281f SHA256 02a164c3e3a77c04b267ef7ba7d7da7c8c606c07262d538d03ae6bc32ef1ead3
+MISC ChangeLog 758 RMD160 127254e4219692747358e6da7d432c83631e7c8a SHA1 f28f81ac1e1b0031dfddba6d93ff43d7882c54c1 SHA256 d8817dc5d57fdf9fd58bdd86e3daaddf1fbc53dedff173bae9402bd9e85a17de
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/app-misc/cursetheweather/cursetheweather-0.6.ebuild b/app-misc/cursetheweather/cursetheweather-0.6.ebuild
index 44600f105..66e74e8b2 100644
--- a/app-misc/cursetheweather/cursetheweather-0.6.ebuild
+++ b/app-misc/cursetheweather/cursetheweather-0.6.ebuild
@@ -2,7 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-PUTHON_DEPEND="2"
+EAPI=2
+PYTHON_DEPEND=2
+PYTHON_USE_WITH=ncurses
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='3.*'
+
inherit distutils
MY_P="CurseTheWeather-${PV}"
@@ -16,9 +21,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sys-libs/ncurses"
-RDEPEND="${DEPEND}"
-
S=${WORKDIR}/${MY_P}
pkg_setup() {