summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-29 11:09:49 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-29 11:09:49 +0000
commitf21f13ba319cd5b05e11868000c828ef96c964d4 (patch)
tree361af0e262349052e7e3f000bc2dd1646d62adcc
parentdev-python/Whoosh: Corrected for multiple PyABI installation (diff)
downloadsunrise-f21f13ba319cd5b05e11868000c828ef96c964d4.tar.gz
sunrise-f21f13ba319cd5b05e11868000c828ef96c964d4.tar.bz2
sunrise-f21f13ba319cd5b05e11868000c828ef96c964d4.zip
dev-python/python-virtkey: Corrected for multiple PyABI installation
svn path=/sunrise/; revision=11925
-rw-r--r--dev-python/python-virtkey/ChangeLog5
-rw-r--r--dev-python/python-virtkey/Manifest4
-rw-r--r--dev-python/python-virtkey/python-virtkey-0.60.0.ebuild11
3 files changed, 13 insertions, 7 deletions
diff --git a/dev-python/python-virtkey/ChangeLog b/dev-python/python-virtkey/ChangeLog
index 00c81c15a..18ba2f89d 100644
--- a/dev-python/python-virtkey/ChangeLog
+++ b/dev-python/python-virtkey/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for dev-python/python-virtkey
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Apr 2011; Justin Lecher <jlec@gentoo.org> python-virtkey-0.60.0.ebuild:
+ Corrected for multiple PyABI installation
+
01 Dec 2010; Alexander van der Mey <alexvandermey@gmail.com>
python-virtkey-0.60.0.ebuild:
Fixed broken SRC_URI due to website address change
diff --git a/dev-python/python-virtkey/Manifest b/dev-python/python-virtkey/Manifest
index c87b0e8c8..577db23aa 100644
--- a/dev-python/python-virtkey/Manifest
+++ b/dev-python/python-virtkey/Manifest
@@ -1,4 +1,4 @@
DIST python-virtkey-0.60.0.tar.gz 40328 RMD160 0ea15667350f1474115759d49225a0e2cdcb3d54 SHA1 2227427b7f519e8246ad7cffe55e6bd58c88f1e7 SHA256 f8de93ded985454484e6d2e52ce86b4c7aae65bc3cd97fc8aa7259def2a091a1
-EBUILD python-virtkey-0.60.0.ebuild 575 RMD160 52e3a8d5157f318a1a0faf1715b15b3118e3dce6 SHA1 367bc50e5ebf2a79ecc338577d275e7454505469 SHA256 1edacad8ef4468c2a90b052074e9b1220165ad43e05e60d118f9eafb01eb3330
-MISC ChangeLog 965 RMD160 3268081703c7ac4828fa3176602d9f69c43ae36a SHA1 bcc3c2320a907077628798fc1c9d1c3f07d71620 SHA256 f8f3a40a685d1dad0d83030ee009da4ecea770190513f399a6a0da11ac52d7f7
+EBUILD python-virtkey-0.60.0.ebuild 586 RMD160 a4119bb5bc39531bbe7afb0cb9f75ab6663ba586 SHA1 692e134b45adba39c25564156f4482e75ffa3328 SHA256 4900cc6db9f03ef7aa512f28ea6608cd48e786c5409dee80b85e19ff775d7a71
+MISC ChangeLog 1087 RMD160 71882d02518fee39ea436dd1f95c0415470bdc64 SHA1 e50085b415f6551c8a45b4802ddc8a4239899fd1 SHA256 35b06f172b1defc432e9114c073eb7d024b814051533640d7d677413a4c246ac
MISC metadata.xml 231 RMD160 6aebfea93d789d2b96ea6d8259dc842dd1fdacd3 SHA1 e10a04c4c18a66af326abc1f40c61b28cc610fae SHA256 48054ea190d00518c1e035fc6663b2368854cdea5ff69a94830e4f9a38260987
diff --git a/dev-python/python-virtkey/python-virtkey-0.60.0.ebuild b/dev-python/python-virtkey/python-virtkey-0.60.0.ebuild
index dd616b34b..0897e9b18 100644
--- a/dev-python/python-virtkey/python-virtkey-0.60.0.ebuild
+++ b/dev-python/python-virtkey/python-virtkey-0.60.0.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
PYTHON_DEPEND=2
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS='3.*'
@@ -9,7 +11,7 @@ RESTRICT_PYTHON_ABIS='3.*'
inherit distutils versionator
DESCRIPTION="Python module to simulate keypresses and get current keyboard layout"
-HOMEPAGE="https://launchpad.net/virtkey"
+HOMEPAGE="https://launchpad.net/virtkey/"
SRC_URI="http://launchpad.net/python-virtkey/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
LICENSE="LGPL-2"
@@ -17,6 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="x11-libs/libXtst
- >=x11-libs/gtk+-2"
+DEPEND="
+ x11-libs/libXtst
+ x11-libs/gtk+:2"
RDEPEND="${DEPEND}"