summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-20 14:26:44 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-08-20 14:26:44 +0000
commit47d673b7c805cacbe7ed592f435a3e8f30a6e272 (patch)
tree5c3d00c43d0d02657924cb647d74ae2569022048 /app-antivirus
parentAutomatic update to categories (diff)
downloadsunrise-47d673b7c805cacbe7ed592f435a3e8f30a6e272.tar.gz
sunrise-47d673b7c805cacbe7ed592f435a3e8f30a6e272.tar.bz2
sunrise-47d673b7c805cacbe7ed592f435a3e8f30a6e272.zip
app-antivirus/clamtk: Add a || die statement to dobin, Add die message to be more verbose, clean-up src_install(), Drop eapi-1 (useless)
svn path=/sunrise/; revision=9082
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamtk/Manifest2
-rw-r--r--app-antivirus/clamtk/clamtk-4.17.ebuild18
2 files changed, 9 insertions, 11 deletions
diff --git a/app-antivirus/clamtk/Manifest b/app-antivirus/clamtk/Manifest
index 07548665d..44dfd3c26 100644
--- a/app-antivirus/clamtk/Manifest
+++ b/app-antivirus/clamtk/Manifest
@@ -1,4 +1,4 @@
DIST clamtk-4.17.tar.gz 245193 RMD160 3d44582fec05987990fe560f20f3f1e5a6e01fb1 SHA1 976c4d7d76be358aefb0c4acfd2581016ff3ff39 SHA256 87cf592bc7550fa8d071f8775b10a38cac98af68e8230f6bec26492189c6299a
-EBUILD clamtk-4.17.ebuild 1210 RMD160 8a95037771ba536dd44f7798487fee103ee12630 SHA1 70b664a1f17668fd97c684a30c66eba75691a7da SHA256 9ab28ae43cc82258159056c7df4b30f7623fa313e6f141390c7ff1a0e1091494
+EBUILD clamtk-4.17.ebuild 1315 RMD160 7e9be348e6d8f235bd1263a8dfe40f5fb202a1a3 SHA1 620b9b3fd4004b70cc9773761a6e4cb9aff6462a SHA256 e50df720e7d15e6542881cd94d882783c79a0fcbbd010883a879b58cd1ef811c
MISC ChangeLog 2391 RMD160 5a48fe6bc02d6f2373f514e33975ecc411ed33e2 SHA1 7574c186c7b77fdce6de264945b42db5733efe2f SHA256 c3422e47b7d31819a6969ac609b2a92392c0bc3d7f151b0406eda380b49864af
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-antivirus/clamtk/clamtk-4.17.ebuild b/app-antivirus/clamtk/clamtk-4.17.ebuild
index e32ddd1d0..2002d7bf3 100644
--- a/app-antivirus/clamtk/clamtk-4.17.ebuild
+++ b/app-antivirus/clamtk/clamtk-4.17.ebuild
@@ -2,8 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="1"
-
inherit eutils perl-module
DESCRIPTION="A frontend for ClamAV using Gtk2-perl"
@@ -37,24 +35,24 @@ src_unpack() {
perlinfo
sed -i -e "s:'/usr/lib':'${VENDOR_LIB}':" clamtk \
|| die "sed failed"
- gunzip clamtk.1.gz || die "gunzip failed"
+ gunzip ${PN}.1.gz || die "gunzip failed"
}
src_install() {
- dobin clamtk || die
+ dobin ${PN} || die "dobin failed"
- doicon clamtk.png
- domenu clamtk.desktop
+ doicon ${PN}.png || die "doicon failed"
+ domenu ${PN}.desktop || die "domenu failed"
- dodoc CHANGES README || die
- doman clamtk.1 || die
+ dodoc CHANGES README || die "dodoc failed"
+ doman ${PN}.1 || die "doman failed"
# The custom Perl modules
perlinfo
insinto ${VENDOR_LIB}/ClamTk
- doins lib/*.pm || die
+ doins lib/*.pm || die "doins failed"
if use nls ; then
- domo po/*.mo || die
+ domo po/*.mo || die "domo failed"
fi
}