summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Lockwood (dunc) <dunc@lemonia.org>2009-01-16 17:41:44 +0000
committerDuncan Lockwood (dunc) <dunc@lemonia.org>2009-01-16 17:41:44 +0000
commit3b9fc52e4a8d511692ac359385743130f0c18318 (patch)
tree8aea198e72d45e38938db3ad7b5962c19cf9f31f /app-emulation
parentnet-misc/anyremote: Version Bump, using src_configure function to match EAPI-... (diff)
downloadsunrise-3b9fc52e4a8d511692ac359385743130f0c18318.tar.gz
sunrise-3b9fc52e4a8d511692ac359385743130f0c18318.tar.bz2
sunrise-3b9fc52e4a8d511692ac359385743130f0c18318.zip
app-emulation/dynamips: New Ebuild for version 0.2.8_rc2 bug 154491. Includes Makefile patch to fix parallel make. Thanks to everyone in #gentoo-sunrise for help
svn path=/sunrise/; revision=7648
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dynamips/ChangeLog8
-rw-r--r--app-emulation/dynamips/Manifest5
-rw-r--r--app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild43
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.8_rc2-parallel_build.patch21
4 files changed, 75 insertions, 2 deletions
diff --git a/app-emulation/dynamips/ChangeLog b/app-emulation/dynamips/ChangeLog
index 21cd22888..6bf6db4f5 100644
--- a/app-emulation/dynamips/ChangeLog
+++ b/app-emulation/dynamips/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-emulation/dynamips
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Jan 2009; Duncan Lockwood (dunc) <dunc@lemonia.org>
+ +dynamips-0.2.8_rc2.ebuild,
+ +files/dynamips-0.2.8_rc2-parallel_build.patch:
+ New Ebuild for version 0.2.8_rc2 bug 154491. Includes Makefile patch to fix
+ parallel make. Thanks to everyone in #gentoo-sunrise for help
+
02 Sep 2008; Chad A Simmons (CCIEChad) <chad.simmons@member.fsf.org>
+dynamips-0.2.7.ebuild, +metadata.xml:
New ebuild for bug 154491 thanks to Sergey Khalavchuck for the RC ebuild and
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
index 71d00c7a3..42deb9e0a 100644
--- a/app-emulation/dynamips/Manifest
+++ b/app-emulation/dynamips/Manifest
@@ -1,4 +1,7 @@
+AUX dynamips-0.2.8_rc2-parallel_build.patch 624 RMD160 de33a8996fc5b51a0be63552fcecbbfe6e3d4c09 SHA1 e343b84b171fa14ff43d6bbdd101db9c225be4f0 SHA256 7a4aa2e56c933199799296335ebfc64f7f74ac10f934eaaf39faabe869b9d907
DIST dynamips-0.2.7.tar.gz 522620 RMD160 1c84f762c65dc2e83e84ee7b046793c71252c7b1 SHA1 6f65a2e92f5d27aca9d8608369cb20c9539a8121 SHA256 f8fc6fc8f66e10f6afcffa832a6071dffeeb9356ed97fe2690bc678d977717ef
+DIST dynamips-0.2.8-RC2.tar.gz 578935 RMD160 0447a4c0cf516bd2b63259881c7625e26d0d838f SHA1 349270690996a1e260b3eceb51ea90f94c25a59e SHA256 a8b377ce631119e285c401fdb7cb4d0bcc600a15508bdffcf337546957e252de
EBUILD dynamips-0.2.7.ebuild 913 RMD160 c19bbebcbe5c915ed1f35b6a2465a72177876c82 SHA1 b4e3415f281ca927b490fb9ac24d7765e8d16791 SHA256 b01ae3880465745976515057618b85ee696f1fcb340ee5d5fa006669e3c468b1
-MISC ChangeLog 365 RMD160 a9508aa47f8f067917bdc29c83bd949246b9dbf4 SHA1 068784d20af39f5e78a98fff05a81b316aac230f SHA256 d0414a8389e8536b132bea2d562dab00f72de12beaadbfabfde72b9f8544583c
+EBUILD dynamips-0.2.8_rc2.ebuild 950 RMD160 de06dbff8493c00a6292a3b285875142496bdc5c SHA1 646f36d50fc15c543bbcae162d4c5bb9ca90d410 SHA256 0c9a5014c84831cd8ba6b551e414405e7d7e6629d56a31e759e9d303a71d6b43
+MISC ChangeLog 645 RMD160 216fbd5bb7dd69237b3754e6bc3ef96c82ba3854 SHA1 e4edeea116d838f0402a18bc798a909a6757d44b SHA256 4b94a6135de4bb4c686a05f291358d76d829dcdbcce14e0cff68216a920f45df
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild b/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild
new file mode 100644
index 000000000..a7ca77981
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+MY_P="${P/_rc/-RC}"
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator"
+SRC_URI="http://www.ipflow.utc.fr/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=net-libs/libpcap-0.9.4
+ dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-parallel_build.patch"
+
+ if use amd64; then
+ sed -i \
+ -e 's:DYNAMIPS_ARCH?=x86:DYNAMIPS_ARCH?=amd64:g' \
+ Makefile || die "sed failed"
+ fi
+}
+
+src_install () {
+ dobin dynamips nvram_export \
+ || die "Installing binaries failed"
+ doman dynamips.1 hypervisor_mode.7 nvram_export.1 \
+ || die "Installing man pages failed"
+ dodoc ChangeLog TODO README README.hypervisor \
+ || die "Installing docs failed"
+}
+
diff --git a/app-emulation/dynamips/files/dynamips-0.2.8_rc2-parallel_build.patch b/app-emulation/dynamips/files/dynamips-0.2.8_rc2-parallel_build.patch
new file mode 100644
index 000000000..a0e7798fa
--- /dev/null
+++ b/app-emulation/dynamips/files/dynamips-0.2.8_rc2-parallel_build.patch
@@ -0,0 +1,21 @@
+--- Makefile.orig 2009-01-16 14:45:30.000000000 +0000
++++ Makefile 2009-01-16 15:02:47.000000000 +0000
+@@ -215,8 +215,7 @@
+ .PHONY: all
+ all: $(PROG) nvram_export
+
+-$(PROG): mips64_microcode_dump.inc ppc32_microcode_dump.inc \
+- $(LEX_C) $(C_OBJS) $(A_OBJS)
++$(PROG): $(LEX_C) $(C_OBJS) $(A_OBJS)
+ @echo "Linking $@"
+ @$(CC) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS)
+
+@@ -246,6 +245,8 @@
+ @echo "Building assembly definitions header file"
+ @./asmdefs
+
++dev_rom.o: mips64_microcode_dump.inc ppc32_microcode_dump.inc
++
+ nvram_export$(BIN_EXT): nvram_export.c
+ @echo "Linking $@"
+ @$(CC) -Wall $(CFLAGS) -o $@ nvram_export.c