summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-11-22 15:00:43 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-11-22 15:00:43 +0000
commit052d71fffbdb651e29c47a80628f18cbb2f57177 (patch)
tree4323ccf24198b6d53b842ed61a75422544d65f8a /dev-db
parentmedia-gfx/mapivi: Rewritten ebuild for bug 133333, thanks to genstef for revi... (diff)
downloadsunrise-052d71fffbdb651e29c47a80628f18cbb2f57177.tar.gz
sunrise-052d71fffbdb651e29c47a80628f18cbb2f57177.tar.bz2
sunrise-052d71fffbdb651e29c47a80628f18cbb2f57177.zip
dev-db/dabo/dabo-0.7.1.ebuild: Stylistic change: remove $@ in src_install, indent RDEPEND properly and reorder variable definitions at the start
svn path=/sunrise/; revision=1965
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/dabo/dabo-0.7.1.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-db/dabo/dabo-0.7.1.ebuild b/dev-db/dabo/dabo-0.7.1.ebuild
index 9f3d42cac..2a6fe4705 100644
--- a/dev-db/dabo/dabo-0.7.1.ebuild
+++ b/dev-db/dabo/dabo-0.7.1.ebuild
@@ -7,24 +7,25 @@ inherit distutils
DESCRIPTION="A 3-tier, cross-platform application development framework written in Python atop the wxPython GUI toolkit"
HOMEPAGE="http://dabodev.com/"
SRC_URI="ftp://dabodev.com/dabo/${P}-mac-nix.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-S=${WORKDIR}/${PN}
-RESTRICT="mirror"
DEPEND=">=dev-python/setuptools-0.6_alpha9"
-
RDEPEND=">=dev-python/wxpython-2.6.1.1
- !>=dev-python/wxpython-2.7
- >=dev-db/sqlite-3.0
- >=dev-python/pysqlite-2.0
- ${DEPEND}"
+ !>=dev-python/wxpython-2.7
+ >=dev-db/sqlite-3.0
+ >=dev-python/pysqlite-2.0
+ ${DEPEND}"
+
+RESTRICT="mirror"
+S=${WORKDIR}/${PN}
src_install() {
${python} setup.py install --root=${D} --no-compile \
- --single-version-externally-managed "$@" || die "setup.py install failed"
+ --single-version-externally-managed || die "setup.py install failed"
dodoc ANNOUNCE AUTHORS ChangeLog README TODO
}