summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Brill (egore) <egore@gmx.de>2008-02-16 00:57:02 +0000
committerChristoph Brill (egore) <egore@gmx.de>2008-02-16 00:57:02 +0000
commitd79872303ad7f1aea0bfd104eac3847fdc2c4a51 (patch)
tree45903411ad3f4669a314dc64288084ccbc8507d3 /dev-libs/libwiimote/files
parentdev-libs/libwiimote: Move eautoreconf out as bootstrap command (diff)
downloadsunrise-d79872303ad7f1aea0bfd104eac3847fdc2c4a51.tar.gz
sunrise-d79872303ad7f1aea0bfd104eac3847fdc2c4a51.tar.bz2
sunrise-d79872303ad7f1aea0bfd104eac3847fdc2c4a51.zip
dev-libs/libwiimote: Add patch to build with --as-needed LDFLAGS
svn path=/sunrise/; revision=5661
Diffstat (limited to 'dev-libs/libwiimote/files')
-rw-r--r--dev-libs/libwiimote/files/libwiimote-9999-ldflags.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libwiimote/files/libwiimote-9999-ldflags.patch b/dev-libs/libwiimote/files/libwiimote-9999-ldflags.patch
new file mode 100644
index 000000000..f88a1473d
--- /dev/null
+++ b/dev-libs/libwiimote/files/libwiimote-9999-ldflags.patch
@@ -0,0 +1,52 @@
+Index: test/Makefile.am
+===================================================================
+--- test/Makefile.am (Revision 80)
++++ test/Makefile.am (Arbeitskopie)
+@@ -1,4 +1,3 @@
+ AM_CFLAGS = -I../src -D_ENABLE_TILT -lm
+ LDADD = ../src/libcwiimote.la
+ noinst_PROGRAMS= test1 test2 test3 test4
+-
+Index: configure.ac
+===================================================================
+--- configure.ac (Revision 80)
++++ configure.ac (Arbeitskopie)
+@@ -5,22 +5,26 @@
+ AC_INIT([libwiimote], [0.4.0], [http://sourceforge.net/projects/libwiimote/])
+ AC_CONFIG_HEADER([config.h])
+
+-
+ VERSION=0.4.0
+ PACKAGE=libcwiimote
+
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+
+ # Checks for programs.
++AC_PROG_CXX
+ AC_PROG_CC
++AC_PROG_CPP
+ AC_PROG_INSTALL
+-AC_PROG_LIBTOOL
++AC_PROG_LN_S
++AC_PROG_MAKE_SET
+ AC_SUBST(LIBTOOL_DEPS)
+ AM_PROG_LIBTOOL
+
+ # Checks for libraries.
+ AC_CHECK_LIB([bluetooth], [hci_remote_name],
+- [], [AC_MSG_ERROR([We require BlueZ])])
++ [], [AC_MSG_ERROR([BlueZ library required, available at http://www.bluez.org/])])
++AC_CHECK_LIB([m], [asin],
++ [], [AC_MSG_ERROR([libm required])])
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -45,7 +49,7 @@
+ AC_CONFIG_FILES([Makefile
+ src/Makefile
+ test/Makefile
+- libwiimote.pc])
++ libwiimote.pc])
+ AC_OUTPUT
+ echo
+ echo $PACKAGE v$VERSION