summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Brill (egore) <egore@gmx.de>2008-02-16 00:23:48 +0000
committerChristoph Brill (egore) <egore@gmx.de>2008-02-16 00:23:48 +0000
commit1d2f5dbf4bc6976620e9c60298ed2eb2a391ca71 (patch)
tree4f57a5b24fa01127be80e9e285a11048603b7dbe /dev-libs/libwiimote/libwiimote-0.4.ebuild
parentAdd use flags for libwiimote (diff)
downloadsunrise-1d2f5dbf4bc6976620e9c60298ed2eb2a391ca71.tar.gz
sunrise-1d2f5dbf4bc6976620e9c60298ed2eb2a391ca71.tar.bz2
sunrise-1d2f5dbf4bc6976620e9c60298ed2eb2a391ca71.zip
dev-libs/libwiimote: New Ebuilds for bug 196324 (the 0.4 release sucks and the live svn is in a flux)
svn path=/sunrise/; revision=5659
Diffstat (limited to 'dev-libs/libwiimote/libwiimote-0.4.ebuild')
-rw-r--r--dev-libs/libwiimote/libwiimote-0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libwiimote/libwiimote-0.4.ebuild b/dev-libs/libwiimote/libwiimote-0.4.ebuild
new file mode 100644
index 000000000..3fe365dfc
--- /dev/null
+++ b/dev-libs/libwiimote/libwiimote-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION="Library to connect to the Nintendo Wii remote"
+HOMEPAGE="http://libwiimote.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tilt force"
+
+DEPEND="net-wireless/bluez-libs
+ net-wireless/bluez-utils"
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-amd64.patch"
+ epatch "${FILESDIR}/${PN}-as-needed.patch"
+
+ use "tilt" || sed -i -e "s:-D_ENABLE_TILT::" config.mk.in
+ use "force" || sed -i -e "s:-D_ENABLE_FORCE::" config.mk.in
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README TODO
+}