summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-09-08 12:23:28 +0000
committerStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-09-08 12:23:28 +0000
commit5d8b30c53d01d17e599f4e44291e1fa5612a0b34 (patch)
tree15a3013dce3c441b34a83ca47269e744757f3f84 /games-rpg/lipsofsuna/lipsofsuna-0.5.0.ebuild
parentdev-ruby/chronic: dev-ruby/chronic is in gentoo-x86, bug #280143 fixed by gra... (diff)
downloadsunrise-5d8b30c53d01d17e599f4e44291e1fa5612a0b34.tar.gz
sunrise-5d8b30c53d01d17e599f4e44291e1fa5612a0b34.tar.bz2
sunrise-5d8b30c53d01d17e599f4e44291e1fa5612a0b34.zip
games-rpg/lipsofsuna: Simple version bump to 0.5.0 of Lips of Suna
svn path=/sunrise/; revision=12370
Diffstat (limited to 'games-rpg/lipsofsuna/lipsofsuna-0.5.0.ebuild')
-rw-r--r--games-rpg/lipsofsuna/lipsofsuna-0.5.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-rpg/lipsofsuna/lipsofsuna-0.5.0.ebuild b/games-rpg/lipsofsuna/lipsofsuna-0.5.0.ebuild
new file mode 100644
index 000000000..acf784c1d
--- /dev/null
+++ b/games-rpg/lipsofsuna/lipsofsuna-0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils games waf-utils
+
+DESCRIPTION="Tongue-in-cheek dungeon crawl game. Client and Server."
+HOMEPAGE="http://lipsofsuna.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-db/sqlite:3
+ >=dev-lang/lua-5.1.0
+ media-libs/flac
+ >=media-libs/glew-1.5
+ >=media-libs/libsdl-1.2
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/mesa
+ media-libs/openal
+ >=media-libs/sdl-ttf-2.0
+ >=net-libs/enet-1
+ >=net-misc/curl-3
+ sci-physics/bullet"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ waf-utils_src_configure \
+ --relpath=false --optimize=true \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"
+}
+
+src_install() {
+ dogamesbin .build/${PN} || die "Installation of gamesbinary failed"
+ insinto "${GAMES_DATADIR}"/${PN}/
+ doins -r data/* || die "Installation of game data failed"
+ doicon misc/${PN}.svg || die "Installation of Icon failed"
+ domenu misc/${PN}.desktop || die "Installation of desktop file failed"
+ prepgamesdirs
+}