summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Kelly (hashendgame) <weldingmaskman@hotmail.com>2007-05-06 21:48:25 +0000
committerJack Kelly (hashendgame) <weldingmaskman@hotmail.com>2007-05-06 21:48:25 +0000
commit561e97e314145c90f56e15693c683da028e7ad37 (patch)
tree3e1ce4bb2cef1cef57c3fe0df2fd02b37eee3e21 /net-fs/httpfs/httpfs-2.06.08.26.ebuild
parentgames-util/bsp: added trailing slash to HOMEPAGE URL (diff)
downloadsunrise-561e97e314145c90f56e15693c683da028e7ad37.tar.gz
sunrise-561e97e314145c90f56e15693c683da028e7ad37.tar.bz2
sunrise-561e97e314145c90f56e15693c683da028e7ad37.zip
net-fs/httpfs: New ebuild for bug 177376 thanks to 'ps'
svn path=/sunrise/; revision=3577
Diffstat (limited to 'net-fs/httpfs/httpfs-2.06.08.26.ebuild')
-rw-r--r--net-fs/httpfs/httpfs-2.06.08.26.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-fs/httpfs/httpfs-2.06.08.26.ebuild b/net-fs/httpfs/httpfs-2.06.08.26.ebuild
new file mode 100644
index 000000000..04ddedfcf
--- /dev/null
+++ b/net-fs/httpfs/httpfs-2.06.08.26.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Fuse-based httpfs file system"
+HOMEPAGE="http://httpfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+RDEPEND="sys-fs/fuse"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ # The script doesn't accept custom CFLAGS. Fix it.
+ sed -i \
+ -e 's:^gcc -c -O2 -g -Wall \(.*\)$:gcc -c ${CFLAGS} \1:' \
+ -e 's:^gcc -s \(.*\):gcc ${CFLAGS} \1:' \
+ make_httpfs || die "sed make_httpfs failed"
+}
+
+src_compile() {
+ ./make_httpfs || die "make_httpfs failed"
+}
+
+src_install() {
+ dobin httpfs
+ dodoc readme.2
+}