summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-12-04 08:55:53 +0000
committerJakub Moc <jakub@gentoo.org>2007-12-04 08:55:53 +0000
commitd121d523b78f914dba7fd9831cc6249a2e1f8e9f (patch)
tree7a6a49ffe36121dffc1debd94ff6d0651b25678b /net-fs/httpfs/httpfs-2.06.08.26.ebuild
parentnet-p2p/freenet/Manifest: New upstream release (diff)
downloadsunrise-d121d523b78f914dba7fd9831cc6249a2e1f8e9f.tar.gz
sunrise-d121d523b78f914dba7fd9831cc6249a2e1f8e9f.tar.bz2
sunrise-d121d523b78f914dba7fd9831cc6249a2e1f8e9f.zip
net-fs/httpfs: Fix cross-compile
svn path=/sunrise/; revision=5149
Diffstat (limited to 'net-fs/httpfs/httpfs-2.06.08.26.ebuild')
-rw-r--r--net-fs/httpfs/httpfs-2.06.08.26.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-fs/httpfs/httpfs-2.06.08.26.ebuild b/net-fs/httpfs/httpfs-2.06.08.26.ebuild
index 1a328f1ed..9c38418bf 100644
--- a/net-fs/httpfs/httpfs-2.06.08.26.ebuild
+++ b/net-fs/httpfs/httpfs-2.06.08.26.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit toolchain-funcs
+
DESCRIPTION="Fuse-based httpfs file system"
HOMEPAGE="http://httpfs.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
@@ -21,8 +23,8 @@ src_unpack() {
unpack ${A}
# The script doesn't accept custom CFLAGS. Fix it.
sed -i \
- -e 's:^gcc -c -O2 -g -Wall \(.*\)$:gcc -c ${CFLAGS} \1:' \
- -e 's:^gcc -s \(.*\):gcc ${CFLAGS} \1:' \
+ -e "s:^gcc -c -O2 -g -Wall \(.*\)$:$(tc-getCC) -c ${CFLAGS} \1:" \
+ -e "s:^gcc -s \(.*\):$(tc-getCC) ${CFLAGS} \1:" \
make_httpfs || die "sed make_httpfs failed"
}