summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-12-04 12:18:59 +0000
committerJakub Moc <jakub@gentoo.org>2007-12-04 12:18:59 +0000
commit2a6904702d301c7edca489523588d9697c069d37 (patch)
treef45c0912369f090d82a9f1e58fe289a7c9877784 /net-fs
parentWipe temporarily (diff)
downloadsunrise-2a6904702d301c7edca489523588d9697c069d37.tar.gz
sunrise-2a6904702d301c7edca489523588d9697c069d37.tar.bz2
sunrise-2a6904702d301c7edca489523588d9697c069d37.zip
Revert previous delete, did not help
svn path=/sunrise/; revision=5176
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/httpfs/ChangeLog15
-rw-r--r--net-fs/httpfs/Manifest4
-rw-r--r--net-fs/httpfs/httpfs-2.06.08.26.ebuild38
-rw-r--r--net-fs/httpfs/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/net-fs/httpfs/ChangeLog b/net-fs/httpfs/ChangeLog
new file mode 100644
index 000000000..fd967afd8
--- /dev/null
+++ b/net-fs/httpfs/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for net-fs/httpfs
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 04 Dec 2007; Jakub Moc <jakub@gentoo.org> httpfs-2.06.08.26.ebuild:
+ Add ~amd64 keyword, fix cross-compile
+
+ 07 May 2007; Jack Kelly (hashendgame) <weldingmaskman@hotmail.com>
+ httpfs-2.06.08.26.ebuild:
+ Added explicit RDEPEND=${DEPEND}
+
+ 06 May 2007; Jack Kelly (hashendgame) <weldingmaskman@hotmail.com>
+ +httpfs-2.06.08.26.ebuild, +metadata.xml:
+ New ebuild for bug 177376 thanks to 'ps'
+
diff --git a/net-fs/httpfs/Manifest b/net-fs/httpfs/Manifest
new file mode 100644
index 000000000..1a1dfdcdf
--- /dev/null
+++ b/net-fs/httpfs/Manifest
@@ -0,0 +1,4 @@
+DIST httpfs_with_static_binaries_2.06.08.26.tar.gz 115384 RMD160 0172c155d38b0ee2e862fdcf8815886ed7d28e48 SHA1 857dfe72b817b01c8a445eb486a047b8c4f8ec02 SHA256 b34d23d9e67b3e7931b2c0dc53fd997dcaf3d6b2126f87a25b51dd00c25e4e65
+EBUILD httpfs-2.06.08.26.ebuild 801 RMD160 e19ccc0480f96b98cb4389dc65997f0991c90e9c SHA1 5d1b213142446d4928ca31ff0bfc00f698f59673 SHA256 421996b8d518b3aef0122e15040357da9baf0699f44461eceb4f4095f3a2a8c5
+MISC ChangeLog 515 RMD160 12d2e81e5aeeac3e29ed7e474d793e1ef4c372ee SHA1 fd7b826e1f1f117066a8318b2526490de199677a SHA256 9186b4898c44d57587246d932f498f79170844594aae6c88698330522a8c2d7e
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-fs/httpfs/httpfs-2.06.08.26.ebuild b/net-fs/httpfs/httpfs-2.06.08.26.ebuild
new file mode 100644
index 000000000..9c38418bf
--- /dev/null
+++ b/net-fs/httpfs/httpfs-2.06.08.26.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Fuse-based httpfs file system"
+HOMEPAGE="http://httpfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="sys-fs/fuse"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ # The script doesn't accept custom CFLAGS. Fix it.
+ sed -i \
+ -e "s:^gcc -c -O2 -g -Wall \(.*\)$:$(tc-getCC) -c ${CFLAGS} \1:" \
+ -e "s:^gcc -s \(.*\):$(tc-getCC) ${CFLAGS} \1:" \
+ make_httpfs || die "sed make_httpfs failed"
+}
+
+src_compile() {
+ ./make_httpfs || die "make_httpfs failed"
+}
+
+src_install() {
+ dobin httpfs
+ newdoc readme.2 readme
+}
diff --git a/net-fs/httpfs/metadata.xml b/net-fs/httpfs/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/net-fs/httpfs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>