summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-01-19 18:27:24 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-01-19 18:27:24 +0000
commit594c1e28839b71e509bac7adf6554da073d0435c (patch)
tree55302727a6f8660bff607ec4339f546fc8ba1b1b /sci-mathematics/alberta
parentsci-visualization/digitizer: Add suggested RDEPEND=${DEPEND}, use EAPI 1, fix... (diff)
downloadsunrise-594c1e28839b71e509bac7adf6554da073d0435c.tar.gz
sunrise-594c1e28839b71e509bac7adf6554da073d0435c.tar.bz2
sunrise-594c1e28839b71e509bac7adf6554da073d0435c.zip
sci-mathematics/alberta: Add suggested RDEPEND=${DEPEND}, add die statements.
svn path=/sunrise/; revision=7704
Diffstat (limited to 'sci-mathematics/alberta')
-rw-r--r--sci-mathematics/alberta/ChangeLog6
-rw-r--r--sci-mathematics/alberta/Manifest4
-rw-r--r--sci-mathematics/alberta/alberta-1.2.1.ebuild8
3 files changed, 12 insertions, 6 deletions
diff --git a/sci-mathematics/alberta/ChangeLog b/sci-mathematics/alberta/ChangeLog
index 5fa460af9..6427ca7dd 100644
--- a/sci-mathematics/alberta/ChangeLog
+++ b/sci-mathematics/alberta/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-mathematics/alberta
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Jan 2009; Christian Ruppert (idl0r) <spooky85@gmail.com>
+ alberta-1.2.1.ebuild:
+ Add suggested RDEPEND=${DEPEND}, add die statements.
+
31 Jul 2006; Jakub Moc <jakub@gentoo.org> alberta-1.2.1.ebuild:
Fix deps to virtual/blas, thanks to Kugelfang
diff --git a/sci-mathematics/alberta/Manifest b/sci-mathematics/alberta/Manifest
index f247657ab..27764d15b 100644
--- a/sci-mathematics/alberta/Manifest
+++ b/sci-mathematics/alberta/Manifest
@@ -1,5 +1,5 @@
DIST alberta-1.2.1.patch.bz2 4262 RMD160 2f0e328f334819dfbaab227fa1cb1332e051ec82 SHA1 5594d15ee09fddfb317ebb48be5314987b045e72 SHA256 3009b7283f62a693b789d0ffd152eb90708ea41aadcd5cfff9937a3f124c7542
DIST alberta-1.2.tar.gz 1081432 RMD160 71ad67275f7de2426a0f6d06e636250de09c4ca0 SHA1 c5d16344e1a6410fa563a1f3a19a19418e2a14a2 SHA256 492a5300db937d968769e509778bbdad121a807216e8f636454ef058f3cda9d1
-EBUILD alberta-1.2.1.ebuild 907 RMD160 2a3af1269b446cd35c11686066e3885f0002ba17 SHA1 50a8f4221464cd8f66d505110e5a8926a2bc82f8 SHA256 af732839d194f230c97665bd8d2bef4ac7aaf50c987c9e7ccb8c6073e4cad0a7
-MISC ChangeLog 379 RMD160 3858e01ce94290248a1f9e4c0ca1627007602966 SHA1 554bfe3fbe61893aed4bab501cb384bfb73195a4 SHA256 0a5135b90ee85ffa1cde2e4e3badf7e2b2d78851ff9cced4403f9eccbffcd8e5
+EBUILD alberta-1.2.1.ebuild 928 RMD160 f101612577b221d4960ce033e2905e862f5ce741 SHA1 f3830ae0c3f80d32eb3722fc28cc4b9a792dd45b SHA256 4687fd27c6991939f98b4de6bda68bf00990bc6a36d6a9d5163c9682bb591ab1
+MISC ChangeLog 521 RMD160 3500e7ede453c3c8502b931c4bf3a051e37f8a92 SHA1 47cb25056f456d84d6fa01943165abb5ac85a7fc SHA256 5ea1d8e9dda635270f451667c0fb8dbb925dd2f08b9bfc8fe7efe1e05372993b
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/sci-mathematics/alberta/alberta-1.2.1.ebuild b/sci-mathematics/alberta/alberta-1.2.1.ebuild
index 0b6951c35..2ea3a36b8 100644
--- a/sci-mathematics/alberta/alberta-1.2.1.ebuild
+++ b/sci-mathematics/alberta/alberta-1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -16,12 +16,14 @@ IUSE=""
DEPEND="virtual/blas
virtual/opengl"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${P/.1}"
src_unpack() {
unpack ${A}
cd "${S}"
+
# A working version of the 1.2.1 patch provided by upstream
epatch "${WORKDIR}/${P}.patch"
}
@@ -30,11 +32,11 @@ src_compile() {
# There exists no ebuild for gltools nor grape, disabling it
econf \
--without-gltools \
- --without-grape || die "econf failed"
+ --without-grape
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README THANKS AUTHORS NEWS
+ dodoc README THANKS AUTHORS NEWS || die "dodoc failed"
}