summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/darbackup/darbackup-0.7.27_pre485.ebuild')
-rw-r--r--app-backup/darbackup/darbackup-0.7.27_pre485.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-backup/darbackup/darbackup-0.7.27_pre485.ebuild b/app-backup/darbackup/darbackup-0.7.27_pre485.ebuild
new file mode 100644
index 000000000..3d673f6ba
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.27_pre485.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/${PN}/${PN}/branches/${PV}"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+
+pkg_setup() {
+ if ! built_with_use app-backup/dar dar32 && ! built_with_use app-backup/dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_postinst() {
+ enewgroup backup
+}
+