summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pysdm/pysdm-0.4.1.ebuild')
-rw-r--r--app-misc/pysdm/pysdm-0.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/pysdm/pysdm-0.4.1.ebuild b/app-misc/pysdm/pysdm-0.4.1.ebuild
new file mode 100644
index 000000000..4dbafedd0
--- /dev/null
+++ b/app-misc/pysdm/pysdm-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Headers: $
+
+inherit python
+
+DESCRIPTION="A PyGTK program for editing fstab"
+HOMEPAGE="http://pysdm.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk
+ >=dev-lang/python-2.4"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc NEWS TODO
+ cd "${PN}"
+ newbin pysdm.py pysdm || die "failed to create executable"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/pysdm/fsdata/
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/pysdm/fsdata/
+ python_mod_cleanup
+}